[svn] r3123 - in trunk/web/freshrpms.net/docs: . i8600 x1

packagers at lists.rpmforge.net packagers at lists.rpmforge.net
Thu Apr 14 20:28:44 CEST 2005


Author: thias
Date: 2005-04-14 20:28:43 +0200 (Thu, 14 Apr 2005)
New Revision: 3123

Added:
   trunk/web/freshrpms.net/docs/x1/
   trunk/web/freshrpms.net/docs/x1/index.html
Modified:
   trunk/web/freshrpms.net/docs/i8600/index.html
   trunk/web/freshrpms.net/docs/index.html
Log:
Added Dell Latitude X1 page, updated the Inspiron 8600 one.


Modified: trunk/web/freshrpms.net/docs/i8600/index.html
===================================================================
--- trunk/web/freshrpms.net/docs/i8600/index.html	2005-04-12 10:37:47 UTC (rev 3122)
+++ trunk/web/freshrpms.net/docs/i8600/index.html	2005-04-14 18:28:43 UTC (rev 3123)
@@ -1,10 +1,10 @@
 <?php
   include("../../inc/main.inc");
-  page_header ("Fedora Core on a Dell Inspiron 8600");
+  page_header ("Fedora Core on the Dell Inspiron 8600");
 ?>
 
 <p class="largetext">
-Fedora Core on a Dell Inspiron 8600
+Fedora Core on the Dell Inspiron 8600
 </p>
 
 <p>
@@ -17,7 +17,7 @@
   <tr>
     <td bgcolor="green">&nbsp; &nbsp; &nbsp;</td>
     <td>DVD+RW drive : NEC ND-5100A</td>
-    <td>Installed from it, burning and de-zoning untested</td>
+    <td>DVD+R(W) burning works fine, de-zoning untested</td>
   </tr>
   <tr>
     <td bgcolor="green">&nbsp; &nbsp; &nbsp;</td>
@@ -25,7 +25,7 @@
     <td>Works fine with default usb-uhci and ehci_hcd</td>
   </tr>
   <tr>
-    <td bgcolor="grey">&nbsp; &nbsp; &nbsp;</td>
+    <td bgcolor="green">&nbsp; &nbsp; &nbsp;</td>
     <td>IEEE1394 Firewire</td>
     <td>Works fine with default video1394 and raw1394</td>
   </tr>
@@ -37,12 +37,12 @@
   <tr>
     <td bgcolor="green">&nbsp; &nbsp; &nbsp;</td>
     <td>Sound chip : Intel 82801DB AC'97</td>
-    <td>Works fine with the default i810_audio OSS module or ALSA snd-intel8x0</td>
+    <td>Works fine with the default ALSA snd-intel8x0 module</td>
   </tr>
   <tr>
     <td bgcolor="orange">&nbsp; &nbsp; &nbsp;</td>
     <td>LCD display : SEC 3150 (1680x1050)</td>
-    <td>Works fine, modeline needs to be added to X's configuration</td>
+    <td>Works fine, but modeline needs to be added to xorg.conf</td>
   </tr>
   <tr>
     <td bgcolor="orange">&nbsp; &nbsp; &nbsp;</td>
@@ -66,9 +66,9 @@
 </p>
 
 <p>
-The ATI Radeon Mobile 9600 Pro in this laptop isn't supported by XFree 4.3.0, other than in vesa mode. I had to do the installation of Fedora Core 1 in text mode, and once the system installed, I had to download binary drivers from <a href="http://www.ati.com/">ATI</a> in order to actually get something acceptable.<br>
-With those closed drivers, there was pretty good OpenGL support, but unfortunately nasty issues with Xv overlay, to which ATI's only answer is to run mplayer with the "GL" output for watching videos :-(.<br>
-I chose this ATI, thinking support would be better than for the NVidia cards which usually come in the 8600, but it looks like it's all the opposite! I've since reinstalled Fedora Core 2 then 3, and xorg-x11 has accelerated 2D support for it, but still no accelerated 3D (as of xorg-x11 6.8.2).
+The ATI Radeon Mobile 9600 Pro in this laptop wasn't supported by XFree 4.3.0, other than in vesa mode. I had to do the installation of Fedora Core 1 in text mode, and once the system installed, I had to download binary drivers from <a href="http://www.ati.com/">ATI</a> in order to actually get something acceptable.<br>
+With those closed drivers, there was pretty good OpenGL support, but unfortunately nasty issues with Xv overlay, to which ATI's only answer was to run mplayer with the "GL" video output :-(.<br>
+I chose this ATI, thinking support would be better than for the NVidia cards that can also be installed in the 8600, but it looks like it's all the opposite! I've since reinstalled Fedora Core 2 then 3, and xorg-x11 has accelerated 2D support for it, but still no accelerated 3D (as of xorg-x11 6.8.2).
 </p>
 
 <?php

Modified: trunk/web/freshrpms.net/docs/index.html
===================================================================
--- trunk/web/freshrpms.net/docs/index.html	2005-04-12 10:37:47 UTC (rev 3122)
+++ trunk/web/freshrpms.net/docs/index.html	2005-04-14 18:28:43 UTC (rev 3123)
@@ -14,6 +14,8 @@
   <li><a href="tips/">Tips</a> - A few quick tips n' tricks</li>
   <li><a href="bios-flash/">BIOS Flash</a> - Flashing a BIOS when you only run GNU/Linux</li>
   <li><a href="oracle/">Oracle 10g Instant Client</a> - Installing Oracle 10g Instant Client on RHEL4</li>
+  <li><a href="i8600/">Fedora Core on the Dell Inspiron 8600</a></li>
+  <li><a href="x1/">Fedora Core on the Dell Latitude X1</a></li>
 </ul>
 <?php
   page_footer ('$Id$');

Added: trunk/web/freshrpms.net/docs/x1/index.html
===================================================================
--- trunk/web/freshrpms.net/docs/x1/index.html	2005-04-12 10:37:47 UTC (rev 3122)
+++ trunk/web/freshrpms.net/docs/x1/index.html	2005-04-14 18:28:43 UTC (rev 3123)
@@ -0,0 +1,99 @@
+<?php
+  include("../../inc/main.inc");
+  page_header ("Fedora Core on the Dell Latitude X1");
+?>
+
+<p class="largetext">
+Fedora Core on the Dell Latitude X1
+</p>
+
+<p>
+<table border="1" cellpadding="5" cellspacing="0">
+  <tr>
+    <td bgcolor="green">&nbsp; &nbsp; &nbsp;</td>
+    <td>Hard drive : Toshiba 60GB UDMA100</td>
+    <td>Working flawlessly, 21MB/s</td>
+  </tr>
+  <tr>
+    <td bgcolor="green">&nbsp; &nbsp; &nbsp;</td>
+    <td>Optical drive : D-Bay Samsung CDRW/DVD SN324S</td>
+    <td>Installed fine from it. When booting with it connected, it appears as an IDE drive, and when hot plugging it, as a usb mass storage device, very practical</td>
+  </tr>
+  <tr>
+    <td bgcolor="green">&nbsp; &nbsp; &nbsp;</td>
+    <td>USB : USB 2.0, EHCI 1.00</td>
+    <td>Works fine with default usb-uhci and ehci_hcd</td>
+  </tr>
+  <tr>
+    <td bgcolor="green">&nbsp; &nbsp; &nbsp;</td>
+    <td>IEEE1394 Firewire</td>
+    <td>Works fine with default video1394 and raw1394</td>
+  </tr>
+  <tr>
+    <td bgcolor="green">&nbsp; &nbsp; &nbsp;</td>
+    <td>GigabitEthernet : Broadcom BCM5751 (Tigon3)</td>
+    <td>Works fine with the default tg3 driver</td>
+  </tr>
+  <tr>
+    <td bgcolor="green">&nbsp; &nbsp; &nbsp;</td>
+    <td>Sound chip : Intel 82801FB AC'97</td>
+    <td>Works fine with the default ALSA snd_intel8x0m module</td>
+  </tr>
+  <tr>
+    <td bgcolor="orange">&nbsp; &nbsp; &nbsp;</td>
+    <td>LCD display : 1280x768</td>
+    <td>Impossible to get 1280x768 with FC4 Test2, stretched 1024x768 at best</td>
+  </tr>
+  <tr>
+    <td bgcolor="orange">&nbsp; &nbsp; &nbsp;</td>
+    <td>Video controller : Intel Mobile 915GM</td>
+    <td>Only supported through vesa in xorg-x11 6.8.2, but by the i810 driver in CVS (to become 6.8.3?)</td>
+  </tr>
+  <tr>
+    <td bgcolor="orange">&nbsp; &nbsp; &nbsp;</td>
+    <td>Wireless : Intel PRO/Wireless LAN 2200BG</td>
+    <td>Works fine with ipw2200 module and <a href="http://freshrpms.net/rpm/ipw2200-firmware">ipw2200-firmware</a></td>
+  </tr>
+  <tr>
+    <td bgcolor="green">&nbsp; &nbsp; &nbsp;</td>
+    <td>Bluetooth : Dell Truemobile</td>
+    <td>Connected internally to the USB bus, works great</td>
+  </tr>
+  <tr>
+    <td bgcolor="red">&nbsp; &nbsp; &nbsp;</td>
+    <td>Modem : Broadcom or Conexant</td>
+    <td>These little beasts simply suck... I only use bluetooth with my mobile phone anyway</td>
+  </tr>
+  <tr>
+    <td bgcolor="red">&nbsp; &nbsp; &nbsp;</td>
+    <td>Secure Data slot</td>
+    <td>Not internally USB connected, too bad, and information seems to indicate that this SD slot would require a specific driver</td>
+  </tr>
+  <tr>
+    <td bgcolor="grey">&nbsp; &nbsp; &nbsp;</td>
+    <td>Compact Flash / MMC slot</td>
+    <td>Not internally USB connected either, but possibly on a Cardbus bridge, which increases the chances of having it work (untested)</td>
+  </tr>
+</table>
+
+<p>
+<h3>Video Controller :</h3>
+</p>
+
+<p>
+As of writing, Fedora Core 4 Test2 installed fine, but only with the vesa driver at 800x600, though. Recompiling xorg-x11 from CVS was required in order for the i810 driver to recognize the card and get accelerated display.<br/>
+I haven't been able to get the display to work at the native resolution of 1280x768, only 1024x768, and it looks quite ugly because of the horizontal stretching. I've tried the "1280patch.c" approach (doesn't work, segfault), the 855resolution approach (changes seem to work, but are never applied)... but nothing seems to work.<br/>
+I haven't tested the VGA output yet, but hopefully it may work with the i810switch utility.
+</p>
+
+<p>
+<h3>Suspend :</h3>
+</p>
+
+<p>
+All resume attempts so far were unsuccessful. When the laptop is closed, it seems that the display turns off without the OS being the one responsible for that. So far I've tried plain and vbetool approaches to no result. I'm seriously considering switching to software suspend (swsusp) for now since these kind of ultra portable laptops are most useful when you can suspend them.
+</p>
+
+<?php
+  page_footer ('$Id$');
+?>




More information about the commits mailing list