[svn] r3456 - in trunk: docs rpms rpms/libetpan rpms/sylpheed-claws

packagers at lists.rpmforge.net packagers at lists.rpmforge.net
Wed Aug 3 13:32:13 CEST 2005


Author: thias
Date: 2005-08-03 13:32:05 +0200 (Wed, 03 Aug 2005)
New Revision: 3456

Added:
   trunk/rpms/libetpan/
   trunk/rpms/libetpan/libetpan.spec
Modified:
   trunk/docs/rpmforge-packages.txt
   trunk/rpms/sylpheed-claws/sylpheed-claws.spec
Log:
Update sylpheed-claws to 0.9.13 and add its new dependency, libetpan.


Modified: trunk/docs/rpmforge-packages.txt
===================================================================
--- trunk/docs/rpmforge-packages.txt	2005-08-02 20:22:25 UTC (rev 3455)
+++ trunk/docs/rpmforge-packages.txt	2005-08-03 11:32:05 UTC (rev 3456)
@@ -586,6 +586,7 @@
 libdvdread matthias
 libdv matthias
 libebml matthias
+libetpan matthias
 libevent dag
 libexif matthias
 libextractor dag

Added: trunk/rpms/libetpan/libetpan.spec
===================================================================
--- trunk/rpms/libetpan/libetpan.spec	2005-08-02 20:22:25 UTC (rev 3455)
+++ trunk/rpms/libetpan/libetpan.spec	2005-08-03 11:32:05 UTC (rev 3456)
@@ -0,0 +1,77 @@
+Summary: Portable mail access library
+Name: libetpan
+Version: 0.38
+Release: 1
+License: BSD
+Group: System Environment/Libraries
+URL: http://www.etpan.org/
+Source: http://dl.sf.net/libetpan/libetpan-%{version}.tar.gz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildRequires: openssl-devel, db4-devel, cyrus-sasl-devel
+
+%description
+The purpose of this mail library is to provide a portable, efficient middleware
+for different kinds of mail access. When using the drivers interface, the
+interface is the same for all kinds of mail access, remote and local mailboxes.
+
+
+%package devel
+Summary: Development files for the libetpan mail access library
+Group: Development/Libraries
+Requires: %{name} = %{version}
+Requires: openssl-devel, db4-devel, cyrus-sasl-devel
+
+%description devel
+The purpose of this mail library is to provide a portable, efficient middleware
+for different kinds of mail access. When using the drivers interface, the
+interface is the same for all kinds of mail access, remote and local mailboxes.
+
+This package contains the files required to develop applications that will use
+the libetpan library.
+
+
+%prep
+%setup
+
+
+%build
+%configure
+%{__make} %{?_smp_mflags}
+
+
+%install
+%{__rm} -rf %{buildroot}
+%makeinstall
+# Fix execution bit on the library so that it gets properly stripped
+%{__chmod} +x %{buildroot}%{_libdir}/*.so.*
+
+
+%clean
+%{__rm} -rf %{buildroot}
+
+
+%post -p /sbin/ldconfig
+
+%postun -p /sbin/ldconfig
+
+
+%files
+%defattr(-, root, root, 0755)
+%doc ChangeLog COPYRIGHT NEWS TODO
+%{_libdir}/*.so.*
+
+%files devel
+%defattr(-, root, root, 0755)
+%doc doc/API.html doc/DOCUMENTATION doc/README.html
+%{_bindir}/libetpan-config
+%{_includedir}/libetpan/
+%{_includedir}/libetpan.h
+%exclude %{_libdir}/*.a
+%exclude %{_libdir}/*.la
+%{_libdir}/*.so
+
+
+%changelog
+* Wed Aug  3 2005 Matthias Saou <http://freshrpms.net/> 0.38-1
+- Initial RPM release.
+


Property changes on: trunk/rpms/libetpan/libetpan.spec
___________________________________________________________________
Name: svn:keywords
   + Id

Modified: trunk/rpms/sylpheed-claws/sylpheed-claws.spec
===================================================================
--- trunk/rpms/sylpheed-claws/sylpheed-claws.spec	2005-08-02 20:22:25 UTC (rev 3455)
+++ trunk/rpms/sylpheed-claws/sylpheed-claws.spec	2005-08-03 11:32:05 UTC (rev 3456)
@@ -12,7 +12,7 @@
 
 Summary: DEVELOPMENT branch of the sylpheed e-mail client
 Name: sylpheed-claws
-Version: 1.9.12
+Version: 1.9.13
 Release: 1%{?extraver:.%{extraver}}
 License: GPL
 Group: Applications/Internet
@@ -24,13 +24,15 @@
 %{?_with_pilot:Requires: pilot-link}
 BuildRequires: gtk2-devel >= 2.0.0, gdk-pixbuf-devel >= 0.8.0
 BuildRequires: flex, pkgconfig, gcc-c++
-BuildRequires: openssl-devel, gpgme03-devel >= 0.3.10, openldap-devel
-BuildRequires: compface-devel, startup-notification-devel
+BuildRequires: openssl-devel, gpgme-devel >= 0.4.5, openldap-devel
+BuildRequires: compface-devel, libetpan-devel >= 0.38
+BuildRequires: startup-notification-devel
 %{?gettextdevel:BuildRequires: gettext-devel}
 BuildRequires: gettext
 %{!?_without_freedesktop:BuildRequires: desktop-file-utils}
 %{!?_without_aspell:BuildRequires: aspell-devel >= 0.50}
 %{?_with_pilot:BuildRequires: pilot-link-devel}
+%{!?_without_printing:BuildRequires: libgnomeprintui22-devel}
 Conflicts: sylpheed
 
 %description
@@ -48,7 +50,7 @@
 
 Available rpmbuild rebuild options :
 --with : pilot
---without : aspell freedesktop
+--without : aspell freedesktop printing
 
 
 %prep
@@ -91,7 +93,7 @@
     --dir %{buildroot}%{_datadir}/applications \
     --add-category Application \
     --add-category Network \
-    %{buildroot}%{_datadir}/gnome/apps/Internet/sylpheed.desktop
+    %{buildroot}%{_datadir}/gnome/apps/Internet/sylpheed-claws.desktop
 %endif
 
 
@@ -111,17 +113,24 @@
 %exclude %{_libdir}/sylpheed-claws/plugins/*.a
 %exclude %{_libdir}/sylpheed-claws/plugins/*.la
 %{_libdir}/sylpheed-claws/plugins/*.so
+%{_libdir}/sylpheed-claws/plugins/*.deps
 %if %{!?_without_freedesktop:1}0
-%{_datadir}/applications/%{desktop_vendor}-sylpheed.desktop
+%{_datadir}/applications/%{desktop_vendor}-sylpheed-claws.desktop
 %else
-%{_datadir}/gnome/apps/Internet/sylpheed.desktop
+%{_datadir}/gnome/apps/Internet/sylpheed-claws.desktop
 %endif
-%{_datadir}/pixmaps/sylpheed.png
+%{_datadir}/pixmaps/sylpheed-claws.png
 %{_datadir}/sylpheed-claws/
 %{_mandir}/man1/sylpheed.1*
 
 
 %changelog
+* Mon Aug  1 2005 Matthias Saou <http://freshrpms.net/> 1.9.13-1
+- Update to 1.9.13.
+- Added new libetpan dependency (for IMAP support).
+- Update gpgme dependency to >= 0.4.5 (no longer gpgme03).
+- Added new libgnomeprintui printing support.
+
 * Fri Jul  8 2005 Matthias Saou <http://freshrpms.net/> 1.9.12-1
 - Update to 1.9.12.
 




More information about the commits mailing list