[svn] r4917 - in trunk/rpms: ettercap libpqxx

packagers at lists.rpmforge.net packagers at lists.rpmforge.net
Mon Nov 20 22:49:44 CET 2006


Author: dries
Date: 2006-11-20 22:49:43 +0100 (Mon, 20 Nov 2006)
New Revision: 4917

Modified:
   trunk/rpms/ettercap/ettercap.spec
   trunk/rpms/libpqxx/libpqxx.spec
Log:
fixes

Modified: trunk/rpms/ettercap/ettercap.spec
===================================================================
--- trunk/rpms/ettercap/ettercap.spec	2006-11-20 13:41:01 UTC (rev 4916)
+++ trunk/rpms/ettercap/ettercap.spec	2006-11-20 21:49:43 UTC (rev 4917)
@@ -11,7 +11,7 @@
 Summary: Multipurpose sniffer/interceptor/logger for switched LAN
 Name: ettercap
 Version: 0.7.3
-Release: 1.2
+Release: 2
 License: GPL
 Group: Applications/Internet
 URL: http://ettercap.sourceforge.net/
@@ -20,7 +20,7 @@
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 
 BuildRequires: openssl-devel, ncurses-devel, gtk2-devel, gcc-c++, libpcap >= 14:0.8.1
-BuildRequires: libnet
+BuildRequires: libnet, libtool-ltdl-devel
 %{?_with_libpcapdevel:BuildRequires:libpcap-devel}
 
 %description
@@ -58,6 +58,9 @@
 %{_datadir}/ettercap/
 
 %changelog
+* Mon Nov 20 2006 Dries Verachtert <dries at ulyssis.org> - 0.7.3-2
+- libtool-ltdl-devel added as buildrequirement, thanks to Ahmed Kamal.
+
 * Sun May 29 2005 Dag Wieers <dag at wieers.com> - 0.7.3-1
 - Updated to release 0.7.3.
 

Modified: trunk/rpms/libpqxx/libpqxx.spec
===================================================================
--- trunk/rpms/libpqxx/libpqxx.spec	2006-11-20 13:41:01 UTC (rev 4916)
+++ trunk/rpms/libpqxx/libpqxx.spec	2006-11-20 21:49:43 UTC (rev 4917)
@@ -4,7 +4,7 @@
 Summary: C++ client API for PostgreSQL
 Name: libpqxx
 Version: 2.6.7
-Release: 1
+Release: 2
 License: BSD
 Group: System Environment/Libraries
 URL: http://pqxx.org/
@@ -13,6 +13,7 @@
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 
 BuildRequires: openssl-devel, postgresql-devel, postgresql-libs, gcc-c++
+Requires: postgresql-devel, pkgconfig
 
 %description
 C++ client API for PostgreSQL. The standard front-end (in the sense of
@@ -32,6 +33,7 @@
 
 %prep
 %setup
+%{__perl} -pi -e "s|.Werror||g;" configure*
 
 %build
 %configure \
@@ -70,6 +72,9 @@
 %exclude %{_libdir}/*.la
 
 %changelog
+* Mon Nov 20 2006 Dries Verachtert <dries at ulyssis.org> - 2.6.7-2
+- Added openssl-devel and pkgconfig requires, thanks to Rex Dieter.
+
 * Mon Nov 13 2006 Dries Verachtert <dries at ulyssis.org> - 2.6.7-1
 - Updated to release 2.6.7.
 




More information about the commits mailing list