[svn] r4930 - in trunk/rpms: audacious-extras blackbox coretrace djvulibre driftnet fish gnochm gnome-schedule gnubiff inkscape kwave libextractor normalize ogmrip opensaml pyvnc2swf qcomicbook rxvt scummvm taskjuggler vnc2swf white_dune xplanet yersinia

packagers at lists.rpmforge.net packagers at lists.rpmforge.net
Fri Nov 24 15:05:26 CET 2006


Author: dries
Date: 2006-11-24 15:05:21 +0100 (Fri, 24 Nov 2006)
New Revision: 4930

Modified:
   trunk/rpms/audacious-extras/audacious-extras.spec
   trunk/rpms/blackbox/blackbox.spec
   trunk/rpms/coretrace/coretrace.spec
   trunk/rpms/djvulibre/djvulibre.spec
   trunk/rpms/driftnet/driftnet.spec
   trunk/rpms/fish/fish.spec
   trunk/rpms/gnochm/gnochm.spec
   trunk/rpms/gnome-schedule/gnome-schedule.spec
   trunk/rpms/gnubiff/gnubiff.spec
   trunk/rpms/inkscape/inkscape.spec
   trunk/rpms/kwave/kwave.spec
   trunk/rpms/libextractor/libextractor.spec
   trunk/rpms/normalize/normalize.spec
   trunk/rpms/ogmrip/ogmrip.spec
   trunk/rpms/opensaml/opensaml.spec
   trunk/rpms/pyvnc2swf/pyvnc2swf.spec
   trunk/rpms/qcomicbook/qcomicbook.spec
   trunk/rpms/rxvt/rxvt.spec
   trunk/rpms/scummvm/scummvm.spec
   trunk/rpms/taskjuggler/taskjuggler.spec
   trunk/rpms/vnc2swf/vnc2swf.spec
   trunk/rpms/white_dune/white_dune.spec
   trunk/rpms/xplanet/xplanet.spec
   trunk/rpms/yersinia/yersinia.spec
Log:
fixes

Modified: trunk/rpms/audacious-extras/audacious-extras.spec
===================================================================
--- trunk/rpms/audacious-extras/audacious-extras.spec	2006-11-22 21:42:54 UTC (rev 4929)
+++ trunk/rpms/audacious-extras/audacious-extras.spec	2006-11-24 14:05:21 UTC (rev 4930)
@@ -14,7 +14,7 @@
 Source: http://audacious-media-player.org/release/audacious-%{version}.tgz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 Requires: audacious = %{version}
-BuildRequires: gtk2-devel, libglade2-devel, gettext-devel
+BuildRequires: gtk2-devel, libglade2-devel, gettext-devel, gcc-c++
 # The bare minimum required to get things to build for the plugins we want
 BuildRequires: taglib-devel, libvorbis-devel
 # To get the pkgconfig file for the Input directory location

Modified: trunk/rpms/blackbox/blackbox.spec
===================================================================
--- trunk/rpms/blackbox/blackbox.spec	2006-11-22 21:42:54 UTC (rev 4929)
+++ trunk/rpms/blackbox/blackbox.spec	2006-11-24 14:05:21 UTC (rev 4930)
@@ -25,7 +25,7 @@
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 BuildRequires: gcc-c++
 %{?_without_modxorg:BuildRequires: XFree86-devel}
-%{!?_without_modxorg:BuildRequires: libX11-devel, libXext-devel}
+%{!?_without_modxorg:BuildRequires: libX11-devel, libXext-devel, libXt-devel}
 
 %description
 Blackbox is a window manager for the X Window environment, which is

Modified: trunk/rpms/coretrace/coretrace.spec
===================================================================
--- trunk/rpms/coretrace/coretrace.spec	2006-11-22 21:42:54 UTC (rev 4929)
+++ trunk/rpms/coretrace/coretrace.spec	2006-11-24 14:05:21 UTC (rev 4930)
@@ -12,7 +12,8 @@
 Source: http://www.arbetsmyra.dyndns.org/coretrace/download/coretrace_v%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 
-#BuildRequires:
+# for asm/string.h
+BuildRequires: glibc-kernheaders
 
 %description
 Coretrace is a tool for debugging of embedded Linux applications. It works

Modified: trunk/rpms/djvulibre/djvulibre.spec
===================================================================
--- trunk/rpms/djvulibre/djvulibre.spec	2006-11-22 21:42:54 UTC (rev 4929)
+++ trunk/rpms/djvulibre/djvulibre.spec	2006-11-24 14:05:21 UTC (rev 4930)
@@ -1,16 +1,28 @@
 # $Id$
 # Authority: matthias
 
+%{?dist: %{expand: %%define %dist 1}}
+
+%{?el4:%define _without_modxorg 1}
+%{?el3:%define _without_modxorg 1}
+%{?el2:%define _without_modxorg 1}
+%{?fc4:%define _without_modxorg 1}
+%{?fc3:%define _without_modxorg 1}
+%{?fc2:%define _without_modxorg 1}
+%{?fc1:%define _without_modxorg 1}
+
 Summary: DjVu viewers, encoders and utilities
 Name: djvulibre
-Version: 3.5.14
-Release: 2
+Version: 3.5.17
+Release: 1
 License: GPL
 Group: Applications/Publishing
 URL: http://djvu.sourceforge.net/
 Source: http://dl.sf.net/djvu/djvulibre-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
-BuildRequires: XFree86-devel, qt-devel, libjpeg-devel
+%{!?_without_modxorg:BuildRequires: libXext-devel}
+%{?_without_modxorg:BuildRequires: XFree86-devel}
+BuildRequires: qt-devel, libjpeg-devel
 BuildRequires: libstdc++-devel, gcc-c++, mozilla, gettext, libtiff-devel
 # Provide these here, they're so small, it's not worth splitting them out
 Provides: mozilla-djvulibre = %{version}-%{release}
@@ -84,10 +96,14 @@
 %{_datadir}/pixmaps/djvu.png
 %{_mandir}/man1/*.1*
 %{_mandir}/ja/man1/*.1*
-%{_datadir}/mimelnk/image/x-djvu.desktop
+%{_libdir}/pkgconfig/ddjvuapi.pc
+#%{_datadir}/mimelnk/image/x-djvu.desktop
 
 
 %changelog
+* Fri Nov 24 2006 Dries Verachtert <dries at ulyssis.org> - 3.5.17-1
+- Updated to release 3.5.17.
+
 * Fri Nov  5 2004 Matthias Saou <http://freshrpms.net/> 3.5.14-2
 - Re-enable the lib/mozilla/ symlink to the plugin.
 - Add source of /etc/profile.d/qt.sh to fix weird detection problem on FC3...

Modified: trunk/rpms/driftnet/driftnet.spec
===================================================================
--- trunk/rpms/driftnet/driftnet.spec	2006-11-22 21:42:54 UTC (rev 4929)
+++ trunk/rpms/driftnet/driftnet.spec	2006-11-24 14:05:21 UTC (rev 4930)
@@ -9,6 +9,7 @@
 
 %{?fc6:%define _with_libpcapdevel 1}
 %{?fc5:%define _with_modxorg 1}
+%{?fc6:%define _with_modxorg 1}
 
 Summary: Sniff the network for images and movies and displays them
 Name: driftnet

Modified: trunk/rpms/fish/fish.spec
===================================================================
--- trunk/rpms/fish/fish.spec	2006-11-22 21:42:54 UTC (rev 4929)
+++ trunk/rpms/fish/fish.spec	2006-11-24 14:05:21 UTC (rev 4930)
@@ -6,6 +6,7 @@
 %{!?dist:%define _with_modxorg 1}
 
 %{?fc5:%define _with_modxorg 1}
+%{?fc6:%define _with_modxorg 1}
 
 Summary: Friendly interactive shell
 Name: fish

Modified: trunk/rpms/gnochm/gnochm.spec
===================================================================
--- trunk/rpms/gnochm/gnochm.spec	2006-11-22 21:42:54 UTC (rev 4929)
+++ trunk/rpms/gnochm/gnochm.spec	2006-11-24 14:05:21 UTC (rev 4930)
@@ -26,6 +26,7 @@
 BuildRequires: python-chm >= 0.7.0, python, pygtk2, pygtk2-libglade, gnome-python2,
 BuildRequires: gnome-python2-bonobo, gnome-python2-gtkhtml2, gnome-python2-gconf
 BuildRequires: scrollkeeper, gettext
+BuildRequires: perl(XML::Parser), intltool
 
 Requires: python-chm >= 0.7.0, python, pygtk2, pygtk2-libglade, gnome-python2
 Requires: gnome-python2-bonobo, gnome-python2-gtkhtml2, gnome-python2-gconf

Modified: trunk/rpms/gnome-schedule/gnome-schedule.spec
===================================================================
--- trunk/rpms/gnome-schedule/gnome-schedule.spec	2006-11-22 21:42:54 UTC (rev 4929)
+++ trunk/rpms/gnome-schedule/gnome-schedule.spec	2006-11-24 14:05:21 UTC (rev 4930)
@@ -19,6 +19,7 @@
 BuildRequires: pkgconfig, pygtk2-devel, glib2-devel, gettext
 # configure checks for crontab and for at
 BuildRequires: vixie-cron, at, gnome-doc-utils
+BuildRequires: perl(XML::Parser), intltool
 Requires: python, pygtk2 >= 2.3, gnome-python2, vixie-cron, at
 
 %description

Modified: trunk/rpms/gnubiff/gnubiff.spec
===================================================================
--- trunk/rpms/gnubiff/gnubiff.spec	2006-11-22 21:42:54 UTC (rev 4929)
+++ trunk/rpms/gnubiff/gnubiff.spec	2006-11-24 14:05:21 UTC (rev 4930)
@@ -18,6 +18,7 @@
 BuildRequires: gettext, libgnomeui-devel, gnome-panel, gcc-c++
 BuildRequires: openssl-devel, libglade-devel, gdk-pixbuf-devel
 BuildRequires: glib2-devel, libglade2-devel, gamin-devel
+BuildRequires: perl(XML::Parser), intltool
 BuildRequires: texinfo
 %{!?dist:BuildRequires: gnome-panel-devel}
 %{?el4:BuildRequires: gnome-panel-devel}

Modified: trunk/rpms/inkscape/inkscape.spec
===================================================================
--- trunk/rpms/inkscape/inkscape.spec	2006-11-22 21:42:54 UTC (rev 4929)
+++ trunk/rpms/inkscape/inkscape.spec	2006-11-24 14:05:21 UTC (rev 4930)
@@ -34,7 +34,7 @@
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 
 #BuildRequires: libsigc++2-devel, gtkmm24-devel, glibmm-devel
-BuildRequires: gtkmm2
+BuildRequires: gtkmm2, lcms-devel
 # >= 2.4
 BuildRequires: libgc-devel,  perl(XML::Parser)
 BuildRequires: gcc-c++, pkgconfig

Modified: trunk/rpms/kwave/kwave.spec
===================================================================
--- trunk/rpms/kwave/kwave.spec	2006-11-22 21:42:54 UTC (rev 4929)
+++ trunk/rpms/kwave/kwave.spec	2006-11-24 14:05:21 UTC (rev 4930)
@@ -14,7 +14,7 @@
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 
 BuildRequires: gcc-c++, libtool, gettext, recode, gsl-devel, kdelibs-devel, ImageMagick, kdesdk
-BuildRequires: libmad-devel, id3lib-devel, flac-devel
+BuildRequires: libmad-devel, id3lib-devel, flac-devel, kdemultimedia-devel
 Requires: ImageMagick
 
 %description

Modified: trunk/rpms/libextractor/libextractor.spec
===================================================================
--- trunk/rpms/libextractor/libextractor.spec	2006-11-22 21:42:54 UTC (rev 4929)
+++ trunk/rpms/libextractor/libextractor.spec	2006-11-24 14:05:21 UTC (rev 4930)
@@ -21,6 +21,7 @@
 BuildRequires: ImageMagick-devel, ImageMagick-c++-devel, exiv2, mpeg2dec-devel
 %{?fc4:BuildRequires: libtool-ltdl-devel}
 %{?fc5:BuildRequires: libtool-ltdl-devel}
+%{?fc6:BuildRequires: libtool-ltdl-devel}
 
 %description
 libextractor is a simple library for meta-data extraction.

Modified: trunk/rpms/normalize/normalize.spec
===================================================================
--- trunk/rpms/normalize/normalize.spec	2006-11-22 21:42:54 UTC (rev 4929)
+++ trunk/rpms/normalize/normalize.spec	2006-11-24 14:05:21 UTC (rev 4930)
@@ -3,6 +3,7 @@
 
 %{!?dist:%define _with_modxorg 1}
 %{?fc5:  %define _with_modxorg 1}
+%{?fc6:  %define _with_modxorg 1}
 
 Summary: Audio file volume normalizer
 Name: normalize

Modified: trunk/rpms/ogmrip/ogmrip.spec
===================================================================
--- trunk/rpms/ogmrip/ogmrip.spec	2006-11-22 21:42:54 UTC (rev 4929)
+++ trunk/rpms/ogmrip/ogmrip.spec	2006-11-24 14:05:21 UTC (rev 4930)
@@ -14,7 +14,7 @@
 BuildRequires: gtk2-devel, libglade2-devel, GConf2-devel, libxml2-devel
 Buildrequires: hal-devel, dbus-glib-devel, enchant-devel
 Buildrequires: libdvdread-devel, libtheora-devel, libvorbis-devel, gocr-devel
-Buildrequires: gettext-devel, intltool
+Buildrequires: gettext-devel, intltool, gcc-c++
 # Not technically build required, but configure checks for it...
 Buildrequires: mplayer, mencoder, ogmtools, vorbis-tools, theora-tools
 BuildRequires: mkvtoolnix, lame

Modified: trunk/rpms/opensaml/opensaml.spec
===================================================================
--- trunk/rpms/opensaml/opensaml.spec	2006-11-22 21:42:54 UTC (rev 4929)
+++ trunk/rpms/opensaml/opensaml.spec	2006-11-24 14:05:21 UTC (rev 4930)
@@ -14,7 +14,7 @@
 Source: http://shibboleth.internet2.edu/downloads/opensaml-%{real_version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 
-BuildRequires: xml-security-c-devel, gcc-c++, xerces-c-devel
+BuildRequires: xml-security-c-devel, gcc-c++, xerces-c-devel, curl-devel
 
 %description
 OpenSAML 1.1 is an open source toolkit for implementing solutions using the 

Modified: trunk/rpms/pyvnc2swf/pyvnc2swf.spec
===================================================================
--- trunk/rpms/pyvnc2swf/pyvnc2swf.spec	2006-11-22 21:42:54 UTC (rev 4929)
+++ trunk/rpms/pyvnc2swf/pyvnc2swf.spec	2006-11-24 14:05:21 UTC (rev 4930)
@@ -58,7 +58,7 @@
 %{__rm} -rf %{buildroot}
 
 %files
-%defattr(-, root, root, 0775}
+%defattr(-, root, root, 0775)
 %doc *.txt *.html
 %{_bindir}/pyvnc2swf
 %{_bindir}/pyvnc2swf-edit

Modified: trunk/rpms/qcomicbook/qcomicbook.spec
===================================================================
--- trunk/rpms/qcomicbook/qcomicbook.spec	2006-11-22 21:42:54 UTC (rev 4929)
+++ trunk/rpms/qcomicbook/qcomicbook.spec	2006-11-24 14:05:21 UTC (rev 4930)
@@ -2,6 +2,16 @@
 # Authority: dries
 # Upstream: Pawel Stolowski <yogin$linux,bydg,org>
 
+%{?dist: %{expand: %%define %dist 1}}
+
+%{?el4:%define _without_modxorg 1}
+%{?el3:%define _without_modxorg 1}
+%{?el2:%define _without_modxorg 1}
+%{?fc4:%define _without_modxorg 1}
+%{?fc3:%define _without_modxorg 1}
+%{?fc2:%define _without_modxorg 1}
+%{?fc1:%define _without_modxorg 1}
+
 Summary: Viewer for comic book archives
 Name: qcomicbook
 Version: 0.3.3
@@ -14,6 +24,7 @@
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 
 BuildRequires: kdelibs-devel, gettext, gcc-c++, imlib2-devel
+%{!?_without_modxorg:BuildRequires: libXmu-devel, libXi-devel}
 
 %description
 QComicBook is a viewer for rar, zip, cbr, and cbz format comic book

Modified: trunk/rpms/rxvt/rxvt.spec
===================================================================
--- trunk/rpms/rxvt/rxvt.spec	2006-11-22 21:42:54 UTC (rev 4929)
+++ trunk/rpms/rxvt/rxvt.spec	2006-11-24 14:05:21 UTC (rev 4930)
@@ -30,7 +30,7 @@
 BuildRequires: libtool
 %{!?_without_freedesktop:BuildRequires: desktop-file-utils}
 %{?_without_modxorg:BuildRequires: XFree86-devel}
-%{!?_without_modxorg:BuildRequires: xorg-x11-proto-devel, libXt-devel}
+%{!?_without_modxorg:BuildRequires: xorg-x11-proto-devel, libXt-devel, libXpm-devel}
 
 Requires: utempter
 

Modified: trunk/rpms/scummvm/scummvm.spec
===================================================================
--- trunk/rpms/scummvm/scummvm.spec	2006-11-22 21:42:54 UTC (rev 4929)
+++ trunk/rpms/scummvm/scummvm.spec	2006-11-24 14:05:21 UTC (rev 4930)
@@ -18,7 +18,7 @@
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 BuildRequires: SDL-devel >= 1.2.2
 BuildRequires: libmad-devel, libogg-devel, libvorbis-devel, flac-devel
-BuildRequires: mpeg2dec-devel, zlib-devel, nasm
+BuildRequires: mpeg2dec-devel, zlib-devel, nasm, gcc-c++
 BuildRequires: desktop-file-utils
 
 %description

Modified: trunk/rpms/taskjuggler/taskjuggler.spec
===================================================================
--- trunk/rpms/taskjuggler/taskjuggler.spec	2006-11-22 21:42:54 UTC (rev 4929)
+++ trunk/rpms/taskjuggler/taskjuggler.spec	2006-11-24 14:05:21 UTC (rev 4930)
@@ -13,7 +13,7 @@
 Source: http://www.taskjuggler.org/download/taskjuggler-%{version}.tar.bz2
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 
-BuildRequires: kdelibs-devel, gcc-c++, kdepim-devel, docbook-dtds
+BuildRequires: kdelibs-devel, gcc-c++, kdepim-devel, docbook-dtds, gettext
 
 %description
 TaskJuggler is a modern and powerful project management tool. Its new approach

Modified: trunk/rpms/vnc2swf/vnc2swf.spec
===================================================================
--- trunk/rpms/vnc2swf/vnc2swf.spec	2006-11-22 21:42:54 UTC (rev 4929)
+++ trunk/rpms/vnc2swf/vnc2swf.spec	2006-11-24 14:05:21 UTC (rev 4930)
@@ -20,7 +20,7 @@
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 
 BuildRequires: libdnet-devel, libstdc++-devel, zlib-devel, gcc-c++
-%{?_with_modxorg:BuildRequires: libXt-devel, libXext, libXaw-devel}
+%{?_with_modxorg:BuildRequires: libXt-devel, libXext-devel, libXaw-devel}
 %{!?_with_modxorg:BuildRequires: XFree86-devel}
 
 %description

Modified: trunk/rpms/white_dune/white_dune.spec
===================================================================
--- trunk/rpms/white_dune/white_dune.spec	2006-11-22 21:42:54 UTC (rev 4929)
+++ trunk/rpms/white_dune/white_dune.spec	2006-11-24 14:05:21 UTC (rev 4930)
@@ -35,11 +35,14 @@
 Patch: gcc.patch
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 BuildRequires: gcc-c++, flex, byacc, zlib-devel
-BuildRequires: libjpeg-devel, libpng-devel, ImageMagick, openmotif-devel
+BuildRequires: libjpeg-devel, libpng-devel, ImageMagick
 %{!?_without_modxorg:BuildRequires: libX11-devel, xorg-x11-server-Xvfb, xorg-x11-proto-devel, libXi-devel}
 %{?_without_modxorg:BuildRequires: XFree86-devel, /usr/X11R6/bin/Xvfb}
 %{!?_without_freeglut:BuildRequires: freeglut-devel}
 %{?_without_freeglut:BuildRequires: glut-devel}
+%{?fc4:BuildRequires: openmotif-devel}
+%{?fc5:BuildRequires: openmotif-devel}
+%{?fc6:BuildRequires: lesstif-devel}
 
 %description
 The white_dune program is a graphical VRML97 editor and animation tool.

Modified: trunk/rpms/xplanet/xplanet.spec
===================================================================
--- trunk/rpms/xplanet/xplanet.spec	2006-11-22 21:42:54 UTC (rev 4929)
+++ trunk/rpms/xplanet/xplanet.spec	2006-11-24 14:05:21 UTC (rev 4930)
@@ -27,7 +27,7 @@
 BuildRequires: libungif-devel, libjpeg-devel, libpng-devel
 BuildRequires: netpbm-devel, libtiff-devel, pango-devel
 %{?_without_modxorg:BuildRequires: XFree86-devel}
-%{!?_without_modxorg:BuildRequires: libX11-devel}
+%{!?_without_modxorg:BuildRequires: libX11-devel, libXt-devel}
 
 %description
 Xplanet was inspired by Xearth, which renders an image of the earth into the

Modified: trunk/rpms/yersinia/yersinia.spec
===================================================================
--- trunk/rpms/yersinia/yersinia.spec	2006-11-22 21:42:54 UTC (rev 4929)
+++ trunk/rpms/yersinia/yersinia.spec	2006-11-24 14:05:21 UTC (rev 4930)
@@ -17,7 +17,7 @@
 Source: http://www.yersinia.net/download/yersinia-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 
-BuildRequires: libnet, libpcap, ncurses-devel
+BuildRequires: libnet, libpcap, ncurses-devel, gtk2-devel
 %{?_with_libpcapdevel:BuildRequires:libpcap-devel}
 
 %description




More information about the commits mailing list