[svn] r6774 - trunk/rpms/perl-Config-IniFiles

packagers at lists.rpmforge.net packagers at lists.rpmforge.net
Tue Apr 21 20:50:50 CEST 2009


Author: dries
Date: 2009-04-21 19:50:50 +0100 (Tue, 21 Apr 2009)
New Revision: 6774

Added:
   trunk/rpms/perl-Config-IniFiles/patch-perl-Config-IniFiles-2.47.patch
Modified:
   trunk/rpms/perl-Config-IniFiles/perl-Config-IniFiles.spec
Log:
fix by Erik Wasser for perl-Config-IniFiles

Added: trunk/rpms/perl-Config-IniFiles/patch-perl-Config-IniFiles-2.47.patch
===================================================================
--- trunk/rpms/perl-Config-IniFiles/patch-perl-Config-IniFiles-2.47.patch	                        (rev 0)
+++ trunk/rpms/perl-Config-IniFiles/patch-perl-Config-IniFiles-2.47.patch	2009-04-21 18:50:50 UTC (rev 6774)
@@ -0,0 +1,9 @@
+diff -ru perl-Config-IniFiles-orig/Makefile.PL perl-Config-IniFiles/Makefile.PL
+--- perl-Config-IniFiles-orig/Makefile.PL	2009-01-21 10:37:49.000000000 +0100
++++ perl-Config-IniFiles/Makefile.PL	2009-04-21 13:47:13.000000000 +0200
+@@ -4,4 +4,5 @@
+ WriteMakefile(
+     'NAME'	=> 'Config::IniFiles',
+     'VERSION_FROM' => 'lib/Config/IniFiles.pm', # finds $VERSION
++    PL_FILES => {},
+ );

Modified: trunk/rpms/perl-Config-IniFiles/perl-Config-IniFiles.spec
===================================================================
--- trunk/rpms/perl-Config-IniFiles/perl-Config-IniFiles.spec	2009-04-21 07:14:29 UTC (rev 6773)
+++ trunk/rpms/perl-Config-IniFiles/perl-Config-IniFiles.spec	2009-04-21 18:50:50 UTC (rev 6774)
@@ -9,17 +9,19 @@
 Summary: Module for reading .ini-style configuration files
 Name: perl-Config-IniFiles
 Version: 2.47
-Release: 1
+Release: 2
 License: distributable
 Group: Applications/CPAN
 URL: http://search.cpan.org/dist/Config-IniFiles/
 
 Source: http://www.cpan.org/modules/by-module/Config/Config-IniFiles-%{version}.tar.gz
+Patch: patch-perl-Config-IniFiles-2.47.patch
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 
 BuildArch: noarch
 BuildRequires: perl
 BuildRequires: perl(ExtUtils::MakeMaker) >= 0:5.00503
+BuildRequires: perl(Module::Build)
 Requires: perl >= 0:5.00503
 
 %description
@@ -27,6 +29,7 @@
 
 %prep
 %setup -n %{real_name}-%{version}
+%patch -p1
 
 %build
 %{__perl} Makefile.PL INSTALLDIRS="vendor" PREFIX="%{buildroot}%{_prefix}"
@@ -50,6 +53,9 @@
 %{perl_vendorlib}/Config/IniFiles.pm
 
 %changelog
+* Tue Apr 21 2009 Dries Verachtert <dries at ulyssis.org> - 2.47-2
+- Added changes by Erik Wasser so it also builds on el4.
+
 * Tue Mar 17 2009 Dries Verachtert <dries at ulyssis.org> - 2.47-1
 - Updated to release 2.47.
 




More information about the commits mailing list