[packagers] Re: incompatible fftw-3-1.1 kde-redhat packaging

Bent Terp bent.terp at ki.se
Mon Oct 16 09:20:26 CEST 2006


On Friday 13 October 2006 18:38, Rex Dieter wrote:
> Morten Kjeldgaard wrote:
> > The problem is that your fftw is version 3.*, so you need to _rename_
> > your package to fftw3.
>
> ...
>
> >In other distros, fftw is version 2.*, but there
> > is no straight upgrade path from version 2 to version 3, so you can't
> > just upgrade the fftw package without breaking all the programs that
> > depend on it. Most distros I am aware of keep two versions fftw and
> > fftw3, which are able to live side-by-side.

Both fedoraextras and atrpms do it the same way as Rex describes, rpmforge 
does it the way Morten wants.

Other distros - Suse, Mandriva, you name em - may have great merit in their 
own, but little relevance to this discussion.

> Let me put it another way (bluntly): it's either the fftw(3) + fftw2 way
> or the highway.  Which would you rather have?

My personal preference would be _one_ provider of fftw regardless of version - 
or at least that all repos with fftw packages use the same numbering scheme. 
But I realise that it is _not_ a trivial thing to achieve; maintaining 
backwards compatibility without staying behind in the age of dinos. 
Compromising usually leads to uniform discontent....

regards,
  Bent



More information about the packagers mailing list