[packagers] rrdtool

Quien Sabe quien-sabe at metaorg.com
Tue Dec 18 21:09:31 CET 2007


when building rrdtool for i386 on centos 5.1 I had to make the change below:

[build at buildbox rrdtool]$ diff -uNr 
~/svn-rpmforge/rpms/rrdtool/rrdtool.spec rrdtool.spec
--- /home/build/svn-rpmforge/rpms/rrdtool/rrdtool.spec  2007-06-07 
01:09:46.000000000 -0700
+++ rrdtool.spec        2007-12-18 13:03:57.000000000 -0700
@@ -40,7 +40,7 @@
 BuildRequires: gcc-c++, openssl-devel, cgilib-devel, libart_lgpl-devel 
 >= 2.0
 BuildRequires: libpng-devel, zlib-devel, freetype-devel
 %{!?_without_python:BuildRequires: python-devel >= 2.3}
-%{!?_without_ruby:BuildRequires: ruby-devel}
+%{!?_without_ruby:BuildRequires: ruby, ruby-devel}
 %{!?_without_tcltk_devel:BuildRequires: tcl-devel, tk-devel}
 %{?_without_tcltk_devel:BuildRequires: tcl, tk}
 Requires: perl >= %(rpm -q --qf '%%{epoch}:%%{version}' perl)

ruby-devel only pulled in ruby-libs which did not have /usr/bin/ruby




More information about the packagers mailing list