[packagers] Shared libraries in RPMforge packages...

Rex Dieter rdieter at math.unl.edu
Tue May 15 20:47:57 CEST 2007


Kjeldgaard Morten wrote:
> 
>>>>> Or, since openexr is api-compatible in this case, rebuilding all 
>>>>> your apps against the latest version is an option.
>>>> In that case it is an error to bump the so-number.
>>> abi != abi
>>
>> arg, meant api != abi
> 
> Heh, well, it's all the same package-wise, because the authors of 
> openexr bumped the major so-number where they probably shouldn't have.

No.

api = source compatible
abi = binary compatible
They rightly bumped soname because the latest release is binary 
incompatible.



More information about the packagers mailing list