[packagers] Re: Missing minimal version on perl-DBD-Pg
dag at wieers.com
Thu Jun 12 17:08:31 CEST 2008
On Thu, 12 Jun 2008, david.barbion at adeoservices.com wrote:
> I've just discovered a problem when using the rpm perl-DBD-Pg-2.2.2. When
> using the library, it stops on an error which explain that perl-DBD-Pg needs
> at least perl-DBI >= 1.52 .
> I'm installing this on a RHEL4.5 which supply version 1.40 of perl-DBI.
> Can you add a minimal version requirements on perl-DBD-Pg like: "Requires:
> perl-DBI >= 1.52" ?
We actually have that for the BuildRequires, but not for the Requires. I
added it now. I am wondering whether we should add all the BuildRequires
by default as Requires as well.
Fact is that the Requires are being added by RPM automatically (based on
use/require statements) but often those do not contain version
information. While the META.yml does contain that information.
I think we should improve that.
Thanks for the feedback, a future build will contain this fix.
-- dag wieers, dag at wieers.com, http://dag.wieers.com/ --
[Any errors in spelling, tact or fact are transmission errors]
More information about the packagers