[packagers] Depsolving problem with gscan2pdf

Alan Bartlett ajb.stxsl at googlemail.com
Mon May 4 13:14:52 CEST 2009


I've hit a problem when attempting to update to the latest version of gscan2pdf.

# yum --enablerepo=rpmforge update gscan2pdf
<snip>
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package gscan2pdf.noarch 0:0.9.28-1.el5.rf set to be updated
--> Processing Dependency: perl(Set::IntSpan) >= 1.10 for package: gscan2pdf
--> Processing Dependency: perl(forks) >= 0.33 for package: gscan2pdf
--> Processing Dependency: perl(forks::shared) for package: gscan2pdf
--> Running transaction check
---> Package gscan2pdf.noarch 0:0.9.28-1.el5.rf set to be updated
--> Processing Dependency: perl(forks) >= 0.33 for package: gscan2pdf
--> Processing Dependency: perl(forks::shared) for package: gscan2pdf
---> Package perl-Set-IntSpan.noarch 0:1.13-1.el5.rf set to be updated
--> Finished Dependency Resolution
gscan2pdf-0.9.28-1.el5.rf.noarch from rpmforge has depsolving problems
  --> Missing Dependency: perl(forks::shared) is needed by package
gscan2pdf-0.9.28-1.el5.rf.noarch (rpmforge)
gscan2pdf-0.9.28-1.el5.rf.noarch from rpmforge has depsolving problems
  --> Missing Dependency: perl(forks) >= 0.33 is needed by package
gscan2pdf-0.9.28-1.el5.rf.noarch (rpmforge)
Error: Missing Dependency: perl(forks::shared) is needed by package
gscan2pdf-0.9.28-1.el5.rf.noarch (rpmforge)
Error: Missing Dependency: perl(forks) >= 0.33 is needed by package
gscan2pdf-0.9.28-1.el5.rf.noarch (rpmforge)

I've tried the usual trick of clearing the cache . . . without any success.

This is not urgent by any means. After all, I have the earlier version
of gscan2pdf installed and usable. ;-)

Alan.



More information about the packagers mailing list