[packagers] Issue with gscn2pdf

Dag Wieers dag at wieers.com
Sun May 10 02:04:47 CEST 2009


On Sat, 9 May 2009, Alan Bartlett wrote:

> Thanks for the fix of gscan2pdf. A new install is now possible. :-)
>
> Just a minor point to note (I don't know if it does have any adverse
> effect on the package operation). On starting from a command line the
> following is observed:
>
> $ gscan2pdf
> gscan2pdf 0.9.29
> Can't locate package Cairo::Context for
> @Gtk2::Gdk::Cairo::Context::ISA at
> /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/forks.pm line
> 3682.
> Can't locate package Cairo::Context for
> @Gtk2::Gdk::Cairo::Context::ISA at
> /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/forks.pm line
> 3682.
> Can't locate package Cairo::Context for
> @Gtk2::Gdk::Cairo::Context::ISA at
> /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/forks.pm line
> 3735.
> Can't locate package Cairo::Context for
> @Gtk2::Gdk::Cairo::Context::ISA at
> /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/forks.pm line
> 3735.
> $
>
> Rather then me blundering around inside a package I have no knowledge
> of, I thought it best if I mention it here.

I didn't see that myself, but I had perl-Cairo installed. If you do not 
have it installed you see those messages. What bothers me is that the 
automatic dependencies failed here.

(The automatic dependencies also failed inside the perl-forks package, 
which was what your previous mail was about)

I will add a new dependency from gscan2pdf to perl-Cairo :-/

-- 
--   dag wieers,  dag at wieers.com,  http://dag.wieers.com/   --
[Any errors in spelling, tact or fact are transmission errors]



More information about the packagers mailing list