[packagers] push problem

Paul Reiber paul at reiber.org
Fri Aug 10 21:06:40 CEST 2012


I see what happened.  I did fork the repo... but then I followed the
instructions here:
https://github.com/repoforge/repoforge.github.com/

Specifically README.md says to do:
git clone git://github.com/repoforge/repoforge.github.com.git
...so anyone following those instructions is going to have this problem.

I'm still figuring out git. I think the right things for me to do next are:

- move my current repoforce.github.com directory aside
- git clone git://github.com/PaulReiber/repoforge.github.com
- copy in the file from the other directory
- git commit -a
- git push
...then, finally, do a pull request on github.

Does that sound right?

Kind regards,
-Paul Reiber


On Fri, Aug 10, 2012 at 1:21 PM, Jeff Lawson <jeff at bovine.net> wrote:

> It looks like you're trying to commit and push directly to the main repo.
>
> You probably want to fork the repo into your own user account, commit to
> your repo, and then do a pull request with your changes.
>
>
>
> On Fri, Aug 10, 2012 at 12:18 PM, Paul Reiber <paul at reiber.org> wrote:
>
>> Hi guys,
>>
>> Yury kindly got me started with details on how to contribute to the
>> website.
>>
>> I have a reworked 'use' page ready to contribute.
>>
>> 'git commit -a' worked just fine.  However, then I get:
>>
>> pbr at Rackspace-PBR:~/repoforge.github.com/use$ git push
>> fatal: remote error:
>>
>>
>>   You can't push to git://github.com/repoforge/repoforge.github.com.git
>>
>>
>>   Use git at github.com:repoforge/repoforge.github.com.git
>>
>> ...what am I missing?  and ideas?
>>
>> Thanks!
>>
>> Kind regards,
>> -Paul Reiber
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.repoforge.org/pipermail/packagers/attachments/20120810/f3e39e06/attachment-0002.html>


More information about the packagers mailing list