[packagers] flash-plugin

Dag Wieers dag at wieers.com
Fri Sep 27 11:33:28 CEST 2013


On Thu, 26 Sep 2013, Stephen Isard wrote:

> flash-plugin.i386 requires libcurl.i686 in order to display flash, but 
> libcurl is not listed as a dependency of the flash-plugin package.
>
> I am running a 32 bit firefox browser on 64 bit Scientific Linux 6.4. Without 
> 32 bit libcurl, flash just gave a blank screen with a "movie not loaded" 
> message.

The reason it is missing is because flash-plugin uses dlopen for libcurl 
during run-time, rather than simply linking to it at compile-time. And 
since it's a binary blob we have no control over this.

I fixed it in the SPEC file, so it will be fixed in the next release.

-- 
-- dag wieers, dag at wieers.com, http://dag.wieers.com/
-- dagit linux solutions, contact at dagit.net, http://dagit.net/

[Any errors in spelling, tact or fact are transmission errors]


More information about the packagers mailing list