[users] Broken RPM: bittorrent-4.1.0-1.2.el4.rf

Patrice Guay froggy at step.polymtl.ca
Thu May 26 14:24:49 CEST 2005


Dries Verachtert wrote:

>On Wednesday 25 May 2005 16:01, Dag Wieers wrote:
>
>>On Wed, 25 May 2005, froggy at step.polymtl.ca wrote:
>>
>>>I don't know if this is the right place to post ...
>>>
>>>The latest RPM release of bittorrent from RHEL4 Dag
>>>repository looks broken (bittorrent-4.1.0-1.2.el4.rf).
>>>
>>>When I launch btdownloadcurses.py, I receive this
>>>message:
>>>  File "/usr/bin/btdownloadcurses.py", line 337
>>>    saveas = config['save_as']
>>>         ^
>>>SyntaxError: invalid syntax
>>>
>>>I'm running Tao Linux 4 on i386. Previous version
>>>runs fine (bittorrent-4.0.1-1.2.el4.rf).
>>>
>>Could you report this to the BitTorrent developers ? I think it is an
>>upstream problem. And maybe try if the GUI version has a problem too.
>>
>>I know they don't spend that much time with the curses-version as most
>>people use bittorrent in GUI mode (in fact they recently fixed a lot of
>>problems with the curses version iirc).
>>
>
>It's only a small change to make it work so it's at least able to show the 
>command line options. I added a small patch as attachment. Patrice: it might 
>be interesting to also add this patch when you send a report to the 
>developers?
>
>If you want to use it immediately: add a ')' at the end of line 336 so it 
>becomes:
>                                      "--save_in"))
>
I've contacted the developpers. A new version of bittorrent (4.1.1) 
available
which fix this bug.

--
Patrice Guay



More information about the users mailing list