[users] mediawiki-1.4.7-1.2.el4.rf.i386.rpm requirements.

Will McDonald wmcdonald at gmail.com
Wed Apr 12 15:11:47 CEST 2006


Guys,

I'm migrating an internal Mediawiki over to a new CentOS 4 system. The
old server's running FC3 and has a tarball install, ideally I want to
stick to properly packaged software as far as possible.

[wmcdonald at willspc ~]$ yum deplist mediawiki
Finding dependencies:
Setting up repositories
Reading repository metadata in from local files
package: mediawiki.i386 1.4.7-1.2.el4.rf
  dependency: tetex-latex
   provider: tetex-latex.i386 2.0.2-22.EL4.7
  dependency: tetex-dvips
   provider: tetex-dvips.i386 2.0.2-22.EL4.7
  dependency: ImageMagick
   provider: ImageMagick.i386 6.0.7.1-14
  dependency: mysql-server >= 3.2.0
   provider: mysql-server.i386 4.1.12-3.RHEL4.1
  dependency: php >= 4.3.11
   Unsatisfied dependency

Looking at the RPMForge mediawiki package, it requires php >= 4.3.11
which isn't available either from RPMForge or CentOS 4 base.
php-4.3.9-3.9 seems to be the latest.

What's the best way to proceed here then? I noticed there are PHP5
packages in the centosplus repo, but those wouldn't be available to an
RHEL system.

Will.



More information about the users mailing list