[users] Subversion 1.4.2 for FC4?

Andre Oliveira da Costa costa at tecgraf.puc-rio.br
Thu Dec 14 18:20:12 CET 2006


Hi Dag,

On Thu, 14 Dec 2006 13:59:01 +0100 (CET)
Dag Wieers <dag at wieers.com> wrote:

> On Thu, 14 Dec 2006, Andre Oliveira da Costa wrote:
> 
> > On Thu, 14 Dec 2006 08:17:16 -0200
> > Andre Oliveira da Costa <costa at tecgraf.puc-rio.br> wrote:
> > 
> > > Hi,
> > > 
> > > we're desperately needing Subversion client 1.4.2 for FC4. I tried to
> > > build it myself from FC6 SRPM but it depends on apr-devel >= 0.9.7. I
> > ...
> > 
> > Correcting myself: BuildRequires is fine for apr on the SPEC file:
> > 
> > BuildRequires: apr-devel >= 0.9.6-1, apr-util-devel >= 0.9.5-1
> > 
> > However, even though versions are compliant:
> > 
> > ~ rpm -q apr-devel
> > apr-devel-0.9.6-3.5
> > 
> > ~ rpm -q apr-util-devel
> > apr-util-devel-0.9.6-2
> > 
> > build fails:
> > 
> > checking for APR... yes
> > checking APR version... 0.9.6
> > wanted regexes are 0\.9\.[7-9] 0\.9\.1[0-9] 1\.
> > configure: error: invalid apr version found
> > error: Bad exit status from /var/tmp/rpm-tmp.64058 (%build)
> >     Bad exit status from /var/tmp/rpm-tmp.64058 (%build)
> > 
> > config.log  on the build dir shows this:
> > 
> > configure:3258: Apache Portable Runtime (APR) library configuration
> > configure:3286: checking for APR
> > configure:3368: result: yes
> > configure:3521: checking APR version
> > configure:3529: result: 0.9.6
> > configure:3542: error: invalid apr version found
> > 
> > Indeed, 0.9.6 doesn't match the regexes 0\.9\.[7-9] 0\.9\.1[0-9] 1\.
> > 
> > Any clues?
> 
> For subversion 1.4.2 you need at least apr 0.9.7. The regexp enforces 
> this. It is sad that subversion requires a more recent apr than most 
> distributions (notably enterprise distribution) ship with.
> 
> This sadly is what happens in Open Source all the time. Applications 
> should be more conservative in what they require, especially if this 
> regards something as important as the subversion 1.4 updates.

Agreed. I gave both apr and apr-utils a try, using apr 0.9.6 SRPM as
a starting point, and here's what I got:

- apr 0.9.7 fails compilation
- apr 0.9.{11,13} compile just fine, all tests pass
- apr-utils 0.9.7 fails compilation
- apr-utils 0.9.{11,13} compile but tests fail

So, AFAICS it's not possible to have apr and apr-utils >= 0.9.6
on FC4 without applying some patches.

BTW: just to try it out, I manually edited 'configure' script for
subversion 1.4.2 and changed the apr version number validation regexes
to accept 0.9.6, and compilation happened just fine. However, I can't
say if this is a good or a bad thing...

Regards,

Andre

-- 
Andre Oliveira da Costa
(costa at tecgraf.puc-rio.br)



More information about the users mailing list