[users] Subversion 1.4.2 for FC4?

Andre Oliveira da Costa costa at tecgraf.puc-rio.br
Thu Dec 14 18:42:53 CET 2006


On Thu, 14 Dec 2006 15:20:12 -0200
Andre Oliveira da Costa <costa at tecgraf.puc-rio.br> wrote:

> Agreed. I gave both apr and apr-utils a try, using apr 0.9.6 SRPM as
> a starting point, and here's what I got:
> 
> - apr 0.9.7 fails compilation
> - apr 0.9.{11,13} compile just fine, all tests pass
> - apr-utils 0.9.7 fails compilation
> - apr-utils 0.9.{11,13} compile but tests fail

Sorry, I mixed it up. apr-utils 0.9.7 compiles, and it can be installed
along with apr 0.9.13, but then it's subversion 1.4.2 that fails
compilation with this:

/local2/costa/redhat/BUILD/subversion-1.4.2/subversion/svn
/local2/costa/redhat/BUILD/subversion-1.4.2/subversion/libsvn_fs_base/.libs/libsvn_fs_base-1.so: undefined reference to `db_create'
/local2/costa/redhat/BUILD/subversion-1.4.2/subversion/libsvn_fs_base/.libs/libsvn_fs_base-1.so: undefined reference to `db_env_create'
/local2/costa/redhat/BUILD/subversion-1.4.2/subversion/libsvn_fs_base/.libs/libsvn_fs_base-1.so: undefined reference to `db_version'
/local2/costa/redhat/BUILD/subversion-1.4.2/subversion/libsvn_fs_base/.libs/libsvn_fs_base-1.so: undefined reference to `db_strerror'
collect2: ld returned 1 exit status
make: *** [subversion/svn/svn] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.6901 (%build)
    Bad exit status from /var/tmp/rpm-tmp.6901 (%build)

=/

Regards,

Andre

-- 
Andre Oliveira da Costa
(costa at tecgraf.puc-rio.br)



More information about the users mailing list