[users] Subversion 1.4.2 for FC4? [SOLVED]

Dag Wieers dag at wieers.com
Fri Dec 15 18:39:27 CET 2006


On Fri, 15 Dec 2006, Andre Oliveira da Costa wrote:

> On Thu, 14 Dec 2006 08:17:16 -0200 Andre Oliveira da Costa <costa at tecgraf.puc-rio.br> wrote:
> 
> > we're desperately needing Subversion client 1.4.2 for FC4. I tried to
> > build it myself from FC6 SRPM but it depends on apr-devel >= 0.9.7. I
> > will try next to upgrade apr myself, but I was wondering if someone
> > could already have done this, or has any tip to share about it (aside
> > from "forget it" ;-)).
> 
> just to followup on this: I finally managed to compile svn 1.4.2 with
> the help of some folks on the svn ML =))
> 
> First thing needed was to upgrade both apr and apr-util to the same
> version (0.9.13), which, of course, makes lots of sense. Building apr
> 0.9.13 was a breeze, I basically used the same spec file from 0.9.6 (had
> to disbale a couple of patches that either had already been applied or
> were already incompatible).
> 
> The reason why I tried mixing different versions was because apr-util
> 0.9.13 build failed because one of its self-tests (testdbm) failed
> consistently. After some attempts, I managed to go through passing an
> additional compilation flag '--with-berkeley-db'.
> 
> Once I got these two installed, subversion 1.4.2 compiled just fine =)
> 
> If anyone is interested on spec files for apr and apr-util, just let me
> know.

I assume that you require the new apr installed to make it work. So it's 
not a solution for people unless they upgrade their apr on RHEL3 and 
RHEL4.

Because of this I will not make any subversion 1.4 packages. The only way 
out is to allow subversion 1.4 to build against apr <= 0.9.6.

Kind regards,
--   dag wieers,  dag at wieers.com,  http://dag.wieers.com/   --
[all I want is a warm bed and a kind word and unlimited power]



More information about the users mailing list