[users] dkms

Dag Wieers dag at wieers.com
Wed Dec 20 20:48:21 CET 2006


On Wed, 20 Dec 2006, Anthony Joseph Seward wrote:

> On Wed, 2006-12-20 at 00:48 +0100, Dag Wieers wrote:
> > On Tue, 19 Dec 2006, Anthony Joseph Seward wrote:
> > 
> > > After installing dkms-ipw3945 and requirements I tried to add the module
> > > to dkms with 
> > > 
> > > dkms add -m ipw3945 -v 1.1.2-1.fc6.rf
> > > 
> > > dkms then complains about the syntak of the dkms.conf file.  Looking at
> > > the version of dkms in rpmforge, it seems to be very old.
> > > 
> > > Does anyone have dkms-ipw3945 working?
> > 
> > The dkms packages made by Matthias do not work with the old, old version 
> > of dkms in RPMforge. We never supported dkms before and the new packages 
> > really earn a proper dkms package. I will make work of it soon, I hope.
> 
> I was able to get things working by installing the dkms from Fedora
> Extras.  For some reason, the much older version at rpmforge is
> installed when I simply do 'yum install dkms'.
> 
> After using yhe sequence 
> 	yum -y --disablerepo=rpmforge install dkms
> 	yum -y install dkms-ipw3945
> everything works.
> 
> 
> I think that if dkms is just removed from the repository for the distros
> where it exists in Extras, then everything will work.  I'm using FC6.

I don't see why Yum doesn't pick up dkms from Fedora Extras, since this 
one is clearly newer.

Either this is a user-induced problem (configuration?) or Yum has a bug.

Anyway, RPMforge will have a newer dkms package (the current one predates 
Fedora) especially for RHEL/CentOS.

Kind regards,
--   dag wieers,  dag at wieers.com,  http://dag.wieers.com/   --
[all I want is a warm bed and a kind word and unlimited power]



More information about the users mailing list