[users] Denyhosts on RHEL3 - problem with Python version

Chris Croome chris at webarchitects.co.uk
Thu Feb 23 11:21:32 CET 2006


Hi

FYI Dag's Denyhosts package [1] is packaged for RHEL3 however this depends on a
later version of Python than RHEL3 comes with -- this is the error message you
get when trying to start it:

  starting DenyHosts:    /usr/bin/denyhosts.py --daemon --config=/etc/denyhosts.conf
  Python >= 2.3 required.  You are using: 2.2.3 (#1, Feb  2 2005, 12:20:51) 
  [GCC 3.2.3 20030502 (Red Hat Linux 3.2.3-49)]
  
  ######################################################################
  
  Visit http://www.python.org and download a more recent version of
  Python.
  
  You should install this version in addition to your current version
  (rather than upgrading your current version) because your system might
  depend on the current version.  After installing the newer version, for
  instance version 2.4, simply invoke DenyHosts explicitly with the new
  version of python, eg:
  
  $ python2.4 /usr/bin/denyhosts.py --daemon --config=/etc/denyhosts.conf
  
  ######################################################################

As suggested I guess installing a source python in /usr/local is probably the
easiest way to fix this... Unless anyone has a later python rpm that
installs in addition to the RHEL3 one...

Chris


[1] http://dag.wieers.com/packages/denyhosts/

-- 
Chris Croome                               <chris at webarchitects.co.uk>
web design                             http://www.webarchitects.co.uk/ 
web content management                               http://mkdoc.com/   



More information about the users mailing list