[users] Amivisd-new and perl-DBI dependency issues in CentOS 4.3

William Albert w.albert at verizon.net
Sun Jun 11 14:45:40 CEST 2006


When trying to install amavisd-new in CentOS 4.3, the installation fails
because it requires perl-DBI 1.43 or later. CentOS 4.3 has perl-DBI 1.40.

Error details:

Loading "fastestmirror" plugin
Setting up Install Process
Setting up repositories
Loading mirror speeds from cached hostfile
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package amavisd-new.i386 0:2.4.1-2.el4.rf set to be updated
--> Running transaction check
--> Processing Dependency: perl(MIME::Parser) for package: amavisd-new
--> Processing Dependency: perl(Net::Server) >= 0.93 for package:
amavisd-new
--> Processing Dependency: cabextract for package: amavisd-new
--> Processing Dependency: perl(BerkeleyDB) for package: amavisd-new
--> Processing Dependency: ncompress for package: amavisd-new
--> Processing Dependency: perl(DBI) >= 1.43 for package: amavisd-new
--> Processing Dependency: perl(Convert::TNEF) for package: amavisd-new
--> Processing Dependency: perl(Mail::Address) for package: amavisd-new
--> Processing Dependency: perl(Archive::Zip) >= 1.14 for package:
amavisd-new
--> Processing Dependency: lzop for package: amavisd-new
--> Processing Dependency: arc >= 5.21e for package: amavisd-new
--> Processing Dependency: perl(Unix::Syslog) for package: amavisd-new
--> Processing Dependency: unrar >= 2.71 for package: amavisd-new
--> Processing Dependency: perl-MailTools for package: amavisd-new
--> Processing Dependency: perl(IO::Stringy) for package: amavisd-new
--> Processing Dependency: zoo >= 2.10 for package: amavisd-new
--> Processing Dependency: perl(Compress::Zlib) >= 1.35 for package:
amavisd-new
--> Processing Dependency: perl(Archive::Tar) for package: amavisd-new
--> Processing Dependency: perl(MIME::Entity) for package: amavisd-new
--> Processing Dependency: perl(MIME::Words) for package: amavisd-new
--> Processing Dependency: perl(Convert::UUlib) for package: amavisd-new
--> Processing Dependency: ripole for package: amavisd-new
--> Processing Dependency: nomarch >= 1.2 for package: amavisd-new
--> Processing Dependency: unarj for package: amavisd-new
--> Processing Dependency: perl(Net::Server::PreForkSimple) for package:
amavisd-new
--> Processing Dependency: freeze for package: amavisd-new
--> Processing Dependency: perl(Compress::Zlib) for package: amavisd-new
--> Processing Dependency: perl(MIME::Tools) >= 5.420 for package:
amavisd-new
--> Processing Dependency: perl(Net::Server) >= 0.87 for package:
amavisd-new
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package perl-Unix-Syslog.i386 0:0.100-1.2.el4.rf set to be updated
---> Package perl-Archive-Tar.noarch 0:1.26-1.2.el4.rf set to be updated
---> Package perl-Net-Server.noarch 0:0.93-1.el4.rf set to be updated
---> Package perl-MailTools.noarch 0:1.67-2.2.el4.rf set to be updated
---> Package ncompress.i386 0:4.2.4-40 set to be updated
---> Package perl-Convert-TNEF.noarch 0:0.17-3.2.el4.rf set to be updated
---> Package lzop.i386 0:1.01-1.2.el4.rf set to be updated
---> Package unarj.i386 0:2.63-0.a.2.el4.rf set to be updated
---> Package perl-MIME-tools.noarch 0:5.420-1.el4.rf set to be updated
---> Package perl-IO-stringy.noarch 0:2.110-1.2.el4.rf set to be updated
---> Package perl-Archive-Zip.noarch 0:1.16-1.2.el4.rf set to be updated
---> Package cabextract.i386 0:1.1-1.2.el4.rf set to be updated
---> Package arc.i386 0:5.21j-0.2.el4.rf set to be updated
---> Package perl-Compress-Zlib.i386 0:1.41-1.2.el4.rf set to be updated
---> Package perl-BerkeleyDB.i386 0:0.27-1.2.el4.rf set to be updated
---> Package zoo.i386 0:2.10-2.2.el4.rf set to be updated
---> Package perl-Convert-UUlib.i386 0:1.051-1.2.el4.rf set to be updated
---> Package freeze.i386 0:2.5.0-1.2.el4.rf set to be updated
---> Package unrar.i386 0:3.6.2-1.el4.rf set to be updated
---> Package nomarch.i686 0:1.3-1.2.el4.rf set to be updated
---> Package ripole.i386 0:0.2.0-1.2.el4.rf set to be updated
--> Running transaction check
--> Processing Dependency: perl(Date::Format) for package: perl-MailTools
Error: Missing Dependency: perl(DBI) >= 1.43 is needed by package
amavisd-new
--> Processing Dependency: perl(Convert::BinHex) for package:
perl-MIME-tools
--> Processing Dependency: perl(DBI) >= 1.43 for package: amavisd-new
--> Processing Dependency: perl(Date::Parse) for package: perl-MailTools
--> Processing Dependency: liblzo.so.1 for package: lzop
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package lzo.i386 0:1.08-4.2.el4.rf set to be updated
---> Package perl-Convert-BinHex.noarch 0:1.119-2.2.el4.rf set to be updated
---> Package perl-TimeDate.noarch 0:1.16-1.2.el4.rf set to be updated
--> Running transaction check
--> Processing Dependency: perl(DBI) >= 1.43 for package: amavisd-new
--> Finished Dependency Resolution




More information about the users mailing list