[users] Strange conflict attempting to install alpine on RHEL4 (CentOS 4.5)

Bart Schaefer barton.schaefer at gmail.com
Sun Aug 26 20:38:12 CEST 2007


There is no pine package on my system, yet alpine refuses to install
because it conflicts with pine.  This seems to be because the alpine
package claims to provide pine 4.64, but also to conflict with it;
therefore it conflicts with itself?

[root at torch schaefer]# rpm -qp --provides /tmp/alpine-0.999-1.el4.rf.i386.rpm
pine = 4.64
alpine = 0.999-1.el4.rf
[root at torch schaefer]# rpm -qp --conflicts /tmp/alpine-0.999-1.el4.rf.i386.rpm
pine

Here's the original attempt to yum install it, before I downloaded the
RPM directly:

[root at torch schaefer]# rpm --rebuilddb
[root at torch schaefer]# rpm -qa | grep pine
[root at torch schaefer]# yum clean all
Cleaning up Everything
1158 headers removed
884 packages removed
37 metadata files removed
0 cache files removed
21 cache files removed
[root at torch schaefer]# yum --exclude=pine\* install alpine
Setting up Install Process
Setting up repositories
[...]
Finished
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for alpine to pack into transaction set.
alpine-0.999-1.el4.rf.i38 100% |=========================| 5.2 kB    00:00
---> Package alpine.i386 0:0.999-1.el4.rf set to be updated
--> Running transaction check
--> Processing Conflict: alpine conflicts pine
--> Finished Dependency Resolution
Error: alpine conflicts with pine



More information about the users mailing list