[users] Strange conflict attempting to install alpine on RHEL4 (CentOS 4.5)

Dag Wieers dag at wieers.com
Mon Aug 27 17:01:30 CEST 2007


On Mon, 27 Aug 2007, Bart Schaefer wrote:

> On 8/27/07, Dag Wieers <dag at wieers.com> wrote:
> > On Mon, 27 Aug 2007, Dag Wieers wrote:
> >
> > > That's funny :) I never thought this could happen when I added those
> > > conflict/provide statements. I think this is a yum/rpm bug as a package
> > > should never conflict with itself.
> >
> > Apparently, RPM does not have a bug as it allows it. Both yum/apt do not
> > allow it though. They should excluded the package itself when checking for
> > conflicts. (Just like they exclude themselves for checking for obsoletes)
>
> I tried directly installing the package with RPM, too, and it also
> reported the conflict.  Which version of RPM did you conclude does
> _not_ have the bug?  I have rpm-4.3.3-22_nonptl.

Ok, I am sorry. I have been mistaken, I apparently tried it out on the
newly build (fixed) package. Indeed, I get this:

	[root at lisse rpms]# rpm -Uhv
	/dar/packages/alpine/alpine-0.999-1.el4.rf.x86_64.rpmerror: Failed dependencies:
	        pine conflicts with alpine-0.999-1.el4.rf.x86_64

(before I wrongly tried with alpine-0.999-2.el4.rf.x86_64)

So, rest assured, a fix is imminent :)

-- 
--   dag wieers,  dag at wieers.com,  http://dag.wieers.com/   --
[Any errors in spelling, tact or fact are transmission errors]



More information about the users mailing list