[users] faad2, mpeg4ip, libavcodec (ffmpeg?)

Dag Wieers dag at wieers.com
Wed Jan 10 16:34:16 CET 2007


On Sat, 23 Dec 2006, Bart Schaefer wrote:

> faad2.i386 0:2.5-1.el4.rf requries mpeg4ip.i386 0:1.5.0.1-1.el4.rf
> which in turn requires libavcodec.so, but no package provides
> libavcodec.so.  It looks like that's supposed to come from ffmpeg, but
> neither ffmpeg nor ffmpeg-devel provides it as libavcodec.so without a
> version number (e.g. libavcodec.so.51).
> 
> In fact, even attempting to install ffmpeg-devel chokes because
> nothing provides libavcodec.so.

I don't see faad2 requiring mpeg4ip ?

[dag at lisse dag]# rpm -qpR /dar/packages/faad2/faad2-2.5-1.el4.rf.i386.rpm 
/sbin/ldconfig  
/sbin/ldconfig  
libc.so.6  
libc.so.6(GLIBC_2.0)  
libc.so.6(GLIBC_2.1)  
libc.so.6(GLIBC_2.1.3)  
libfaad.so.0  
libm.so.6  
libm.so.6(GLIBC_2.0)  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1

[dag at lisse dag]# rpm -qpR /dar/packages/faad2/faad2-2.5-1.el4.rf.x86_64.rpm 
/sbin/ldconfig  
/sbin/ldconfig  
libc.so.6()(64bit)  
libc.so.6(GLIBC_2.2.5)(64bit)  
libfaad.so.0()(64bit)  
libm.so.6()(64bit)  
libm.so.6(GLIBC_2.2.5)(64bit)  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1

The mpeg4ip problem I do see, but since it is not installable, nothing 
could have linked with it.

So I'm wondering if I by mistake released a wrong package with the same 
name that caused this problem.

[dag at lisse dag]# rpm -q ffmpeg mplayer xine faad2 faac
ffmpeg-0.4.9-0.7.20061215.el4.rf.x86_64
mplayer-1.0-0.33.rc1.el4.rf.x86_64
xine-0.99.4-8.el4.rf.x86_64
faad2-2.5-1.el4.rf.x86_64
faac-1.25-2.el4.rf.x86_64

What does rpm -qpi faad2 say ?

Kind regards,
--   dag wieers,  dag at wieers.com,  http://dag.wieers.com/   --
[all I want is a warm bed and a kind word and unlimited power]



More information about the users mailing list