[users] faad2, mpeg4ip, libavcodec (ffmpeg?)

Jim Perrin jperrin at gmail.com
Wed Jan 10 17:25:09 CET 2007


> Ok, want to hear my assessement of the situation ?

Sure.

> The problem is yum (once again). Yum tries to speed up its operation by
> not considering anything else than the highest version of a specific
> package and only considers the alphabetic first package providing
> something.
>
> In this case apparently both mpeg4ip and libmp4v2 provide the same library
> and as such yum only considers mpeg4ip.
>
> I do not use yum for this and many other reasons and therefor haven't seen
> the problem. When the first report was made I looked into it shortly but
> couldn't find anything unusual except with the mpeg4ip package, which is
> an old package that I may have to obsolete.
>
> Apt on the other hand oversees anything that is available, and since
> mpeg4ip is not helping to satisfy a complete set of dependencies, it
> doesn't consider it as a solution.
>
> In this case, try to install libmp4v2 manually with yum and then try again
> a yum update.

This seems to work as a solution. Thanks, and again, your packaging
efforts are greatly appreciated.


> Or simply move to apt instead :)

I'd really rather not if I don't have to. RHEL5 is moving to yum,
centos ships with yum, and I'd like to not have to add  additional kit
unless it's necessary (read: I'm lazy).

-- 
During times of universal deceit, telling the truth becomes a revolutionary act.
George Orwell



More information about the users mailing list