[users] youtube-dl requiring python >= 2.4

Dries Verachtert dries at ulyssis.org
Sun Jan 14 23:31:41 CET 2007


On Friday January 12 2007 10:28 am, Ralph Angenendt wrote:
> Moin,
>
> as of today the package "youtube-dl" suddenly requires python >=2.4,
>
> which clearly isn't available on either RHEL4 nor RHEL3:
> | [admin at forge dag]$ rpm -qpR
> | el4/en/i386/RPMS.dag/youtube-dl-0-0.2007.01.01.el4.rf.noarch.rpm
> | el3/en/i386/RPMS.dag/youtube-dl-0-0.2007.01.01.el3.rf.noarch.rpm
> | /usr/bin/env
> | python >= 2.4
> | rpmlib(CompressedFileNames) <= 3.0.4-1
> | rpmlib(PayloadFilesHavePrefix) <= 4.0-1
> | /usr/bin/env
> | python >= 2.4
> | rpmlib(CompressedFileNames) <= 3.0.4-1
> | rpmlib(PayloadFilesHavePrefix) <= 4.0-1
>
> Can that be fixed? Or: can youtube-dl be removed from the RHEL3/4 trees
> if it isn't fixable?

The latest youtube-dl requires optparse (python >= 2.3) and cookielib (python 
>= 2.4). Moritz Barsnick mailed me this some days ago. So the spec file now 
contains Requires:python>=2.4 . I'll remove the rpms for rhel3/rhel4.

It might also be possible to get it working with some rpms from 
http://www.python.org/pyvault/ 

kind regards and thanks for the help,
Dries




More information about the users mailing list