[users] Re: dkms-fuse package doesn't work on RHEL4/CentOS4

Bart Schaefer barton.schaefer at gmail.com
Tue Jul 24 04:29:56 CEST 2007


> Sorry, anybody have ideas on this?  Thanks!

I have installed dkms-fuse on centos 5, but on centos 4 I'm using
fuse-2.6.5-1.el4.rf, which appears to be newer than the dkms-fuse
package ... so you might try that instead.  It seems to be working
fine for me.

> On Wed, Jul 18, 2007 at 05:37:02PM +0800, Yan Li wrote:
> > Hi All,
> >
> > I believe this is a problem of the dkms-fuse package.  It doesn't work
> > on RHEL4U5 (i386, same on CentOS 4.5).
> >
> > I installed dkms-fuse by using yum, but "modprobe fuse" failed and I
> > following messages in dmesg:
> > fuse: Unknown symbol mutex_destroy
> >
> > Some searching on google suggested that this is a know issue of fuse
> > on RHEL4 because it's kernel doesn't support "mutex_destroy", and in
> > order to make it work on el4 kernel this patch is needed:
> > http://202.45.137.9/fuse-mutex_destroy.patch



More information about the users mailing list