[users] Error trying to install mplayer

Devin Henderson devin.lists at gmail.com
Mon Jun 11 18:10:48 CEST 2007


Dag,

I enabled the atrpms repo and now things are working. The libdirectfb
package from atrpms was installed to satisfy the deps and now I'm not
getting errors. Could it be that for some reason the directfb package is not
properly reporting that it provides libdirectfb-0.9.so.25 ?

Anyway, just FYI. Maybe this will shed light on the whole thing. Maybe not.

Cheers,
Devin


On 6/7/07, Devin Henderson <devin.lists at gmail.com> wrote:
>
> Yes, this is very strange. directfb is not excluded. Maybe i'll take a
> look at smart. Thanks.
>
> Devin
>
>
> On 6/7/07, Dag Wieers < dag at wieers.com> wrote:
> >
> > On Thu, 7 Jun 2007, Devin Henderson wrote:
> >
> > > I was getting this error during yum update--it was attempting to
> > update
> > > mplayer. I uninstalled mplayer so that yum update would finish without
> > error
> > > but I still get the same error now trying to reinstall mplayer. For
> > some
> > > reason it complains about missing libdirectfb-0.9.so.25 but the
> > directfb
> > > package provides this file. What gives?! Thanks, Devin
> > >
> > >
> > > [root at six19 devin]# yum install mplayer*
> > > Loading "installonlyn" plugin
> > > Setting up Install Process
> > > Setting up repositories
> > > Reading repository metadata in from local files
> > > Reducing CentOS 5 - i386 - ATrpms to included packages only
> > > Finished
> > > Excluding Packages from Red Hat Enterprise 5 - RPMforge.net - dag
> > > Finished
> > > Parsing package install arguments
> > > Resolving Dependencies
> > > --> Populating transaction set with selected packages. Please wait.
> > > ---> Package mplayerplug-in.i386 0:3.40-1.el5.rf set to be updated
> > > ---> Package mplayer-skins.noarch 0:1.8-1.nodist.rf set to be updated
> > > ---> Package mplayer.i386 0:1.0-0.35.rc1try2.el5.rf set to be updated
> > > --> Running transaction check
> > > --> Processing Dependency: libdirectfb-0.9.so.25 for package: mplayer
> > > --> Finished Dependency Resolution
> > > Error: Missing Dependency: libdirectfb-0.9.so.25 is needed by package
> > > mplayer
> >
> > This file is in the directfb-0.9.25 package. I have no clue why your Yum
> > does not satisfy that dependency. Maybe you have excluded directfb from
> > RPMforge ?
> >
> > In that case, you are better of using smart which is much more
> > intelligent
> > to cherry pick its dependencies (or allows you to make concise
> > decisions).
> >
> > Kind regards,
> > --   dag wieers,  dag at wieers.com,  http://dag.wieers.com/    --
> > [all I want is a warm bed and a kind word and unlimited power]
> >
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.repoforge.org/pipermail/users/attachments/20070611/8405325a/attachment-0004.html>


More information about the users mailing list