[users] Re: [CentOS] Red Hat Enterprise Linux 5 and CentOS 5 extras packages

Bart Schaefer barton.schaefer at gmail.com
Wed Mar 14 17:08:03 CET 2007


On 3/14/07, Dag Wieers <dag at wieers.com> wrote:
>
>  + Upgrading from RHEL4 to RHEL5 using Anaconda does work. Even when
>    people do not recommend it for various reasons. You should be able to
>    update your packages directly to EL5.

For the record, upgrading via "yum upgrade" does not appear to work.
I proceeded as follows (using vmware so I could revert snapshots if
anything went wrong):

: mv /etc/yum.repos.d /etc/yum.repos.d.CentOS4
: rpm -Uvh centos-release-4.92-4.i386.rpm
: cp /etc/yum.repos.d.CentOS4/rpmforge.repo /etc/yum.repos.d
: yum upgrade yum

The end result (half an hour of dependency resolution later) is 27
packages that have dependencies on at least 30 other packages that are
not available, plus 2 conflicts.  So I tried a straight

: yum upgrade

which leaves me with the following:

Error: Unable to satisfy dependencies
Error: Package VFlib2 needs libttf.so.2, this is not available.
Error: Package crypto-utils needs libnewt.so.0.51, this is not available.
Error: Package subversion needs libaprutil-0.so.0, this is not available.
Error: Package kudzu needs kernel < 2.6.13, this is not available.
Error: Package seamonkey needs seamonkey-nss = 1.0.8-0.2.el4.centos,
this is not available.
Error: Package seamonkey needs seamonkey-nspr = 1.0.8-0.2.el4.centos,
this is not available.
Error: Package subversion needs libapr-0.so.0, this is not available.
Error: Package autofs needs kernel < 2.6.17, this is not available.
Error: Package wine-core needs /usr/X11R6/bin/xmessage, this is not available.
Error: Package hal needs kernel < 2.6.17, this is not available.
Error: Package initscripts needs kernel < 2.6.12, this is not available.
Error: Package subversion needs libneon.so.24, this is not available.
Error: Package newt-perl needs libnewt.so.0.51, this is not available.
Error: Package nfs-utils needs libevent-1.1a.so.1, this is not available.



More information about the users mailing list