[users] Trying to install rar from the rpmforge repo

Dag Wieers dag at wieers.com
Mon Mar 19 11:58:50 CET 2007


On Mon, 19 Mar 2007, Rohan Walsh wrote:

> On Sun, 2007-03-18 at 07:38 +0100, Henning Markussen wrote:
> 
> > I'm trying to install rar from the rpmforge repo.
> > But it seems the package that is build for rhel4 needs glibc 2.4.
> > 
> > But centos 4.4 only have a 2.3
> > 
> > Or am I missing something ?
> 
> got rar installed on CentOS 4.4 here
> try:
> # yum install rar-3.5.1

The problem is that rar is a binary. It has not been compiled by us.
As a result RPM gets its dependencies from the binaries and they include 
more (and newer) information than the system provides.

Two possibilities:

 + Remove the newer version so yum doesn't complain (consider apt if this 
   behaviour is bothering you, apt picks the most suitable candidate)
   I do not see this as a real problem even though yum fails on it.

 + Manually remove the wrong dependencies from the package, which is a 
   hard thing to do since that is very specific to the distribution.

The last option for me is the proper one.

Kind regards,
--   dag wieers,  dag at wieers.com,  http://dag.wieers.com/   --
[all I want is a warm bed and a kind word and unlimited power]



More information about the users mailing list