[users] Installation of amavisd-new fails on el4 with wrong perl-DBI version

Ralph Angenendt ra+rpmforge at br-online.de
Mon May 7 14:53:45 CEST 2007


Morning.

Bug report 1 of 2:

Installation of amavisd-new fails with:

Erro: Missing Dependency: perl(DBI) >= 1.43 is needed by package amavisd-new 

Installation "succeeds" if I install perl-DBI from CentOS 4 first (but
which is only at perl(DBI) 1.40-8). 

This is strange, as the spec file *requires* version 1.43 - perl(DBI) >=
1.43

perl-DBI from CentOS 4 provides "perl(DBI)" without *any* version
number. Might this be the reason?


"Success": It's trying to change files to id clamav, which doesn't exist
when installing:

id: clamav: No such user
usermod: user clamav does not exist

This is from the scripts section. But I just saw your "fixme":

### FIXME: If clamd is installed, add user clamav to group amavis

Cheers,

Ralph
-- 
Ralph Angenendt......ra at br-online.de | .."Text processing has made it possible
Bayerischer Rundfunk...80300 München | ....to right-justify any idea, even one
Programmbereich.Bayern 3, Jugend und | .which cannot be justified on any other
Multimedia.........Tl:089.5900.16023 | ..........grounds." -- J. Finnegan, USC
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://lists.repoforge.org/pipermail/users/attachments/20070507/8ba07ec7/attachment.sig>


More information about the users mailing list