[users] repoview on Centos 5

Dag Wieers dag at wieers.com
Mon Nov 5 20:09:16 CET 2007


On Tue, 6 Nov 2007, Maulvi Bakar wrote:

> I am having a bit trouble in getting the repoview to work.  I am using the
> repoview from rpmforge, specifically the el5.  I've been getting "No yum
> parsing routines found. Please see README." errors.  I am getting this error
> when I'm configuring and running mrepo.
>
> Even when I simply run "# repoview" from shell (independent from mrepo), I
> still get the same error.
>
> I thought it might be the python-celementtree as opposed to
> python-elementtree, so I've tried the
> python-elementtree-1.2.6-7.el5.test.i386.rpm from dag's which according to
> the release notes - "This package also includes the C implementation,
> %{real_version_celementtree}.".
>
> Please note, I couldn't replace python-elementtree with python-celementtree
> from rpmforge as repoview itself requires python-elementtree and even after
> using the python-elementtree-1.2.6-7.el5.test.i386.rpm, it is still no go.
>
> The error message told me to read the repoview's README, which I did but it
> didn't seem to provide additional info.  Even followed the 'requirements'
> instructions, but somehow I don't that's the one either..  I'm attaching the
> relevant parts of the README below..
>
> Please help!

I build the repoview 0.6.1 for EL5 now. The Fedora package seems to
indicate it requires python 3.0 but the Fedora packages have never been a
good indicator for requirements so I hope everything goes well :)

-- 
--   dag wieers,  dag at wieers.com,  http://dag.wieers.com/   --
[Any errors in spelling, tact or fact are transmission errors]



More information about the users mailing list