[users] Problems with Latest yum update and Gzip deps

Nigel Frankcom nigel at blue-canoe.com
Sun Nov 11 06:35:37 CET 2007


Hi All,

Is anyone else having problems installing the latest Gzip updates via yum? I'm
getting errors on my 32 bit CentOS 4.5 and 5 machines as below. My 64 bit
machines ran in without any problems.

>Resolving Dependencies
>--> Populating transaction set with selected packages. Please wait.
>---> Package perl-Compress-Raw-Zlib.i386 0:2.006-1.el4.rf set to be updated
>---> Package perl-Crypt-SSLeay.i386 0:0.57-1.el4.rf set to be updated
>---> Package perl-Compress-Zlib.noarch 0:2.007-1.el4.rf set to be updated
>--> Running transaction check
>--> Processing Dependency: perl(IO::Compress::Gzip::Constants) >= 2.006 for package: perl-Compress-Zlib
>--> Processing Dependency: perl(IO::Uncompress::Gunzip) >= 2.006 for package: perl-Compress-Zlib
>--> Processing Dependency: perl(IO::Compress::Gzip) >= 2.006 for package: perl-Compress-Zlib
>--> Finished Dependency Resolution
>Error: Missing Dependency: perl(IO::Compress::Gzip::Constants) >= 2.006 is needed by package perl-Compress-Zlib
>Error: Missing Dependency: perl(IO::Uncompress::Gunzip) >= 2.006 is needed by package perl-Compress-Zlib
>Error: Missing Dependency: perl(IO::Compress::Gzip) >= 2.006 is needed by package perl-Compress-Zlib

I've tried manually installing via cpan to no avail.

One thing I do note is that on the affected boxen the currently installed
version of the problem packages is 2.0008.

I appreciate this may not be the correct place to ask this, if so, any pointers
would be appreciated.

Kind regards

Nigel.



More information about the users mailing list