[users] Missing deps for updated mplayer package

Dag Wieers dag at wieers.com
Fri Nov 23 20:18:30 CET 2007


On Fri, 23 Nov 2007, Yury V. Zaytsev wrote:

> Just tried to update mplayer, but run into the deps problem. Could
> someone please take care of this?
>
> The update log goes below:
>
> [zyv at pride ~]$ sudo yum update
> Loading "installonlyn" plugin
> Loading "priorities" plugin
> Setting up Update Process
> Setting up repositories
> Reading repository metadata in from local files
> Excluding Packages from CentOS-5 - Plus
> Finished
> 0 packages excluded due to repository priority protections
> Resolving Dependencies
> --> Populating transaction set with selected packages. Please wait.
> ---> Downloading header for mplayer to pack into transaction set.
> mplayer-1.0-0.37.rc1try2. 100% |=========================|  43 kB
> 00:02
> ---> Package mplayer.i386 0:1.0-0.37.rc1try2.el5.rf set to be updated
> --> Running transaction check
> --> Processing Dependency: libtwolame.so.0 for package: mplayer
> --> Restarting Dependency Resolution with new changes.
> --> Populating transaction set with selected packages. Please wait.
> ---> Downloading header for twolame to pack into transaction set.
> twolame-0.3.10-1.el5.rf.i 100% |=========================| 3.9 kB
> 00:00
> ---> Package twolame.i386 0:0.3.10-1.el5.rf set to be updated
> --> Running transaction check
> --> Processing Dependency: libsndfile.so.1(libsndfile.so.1.0) for
> package: twolame
> --> Processing Dependency: libsndfile.so.1 for package: twolame
> --> Restarting Dependency Resolution with new changes.
> --> Populating transaction set with selected packages. Please wait.
> ---> Downloading header for libsndfile to pack into transaction set.
> libsndfile-1.0.17-1.el5.r 100% |=========================| 5.5 kB
> 00:00
> ---> Package libsndfile.i386 0:1.0.17-1.el5.rf set to be updated
> --> Running transaction check
> --> Processing Dependency: libFLAC.so.7 for package: libsndfile
> --> Finished Dependency Resolution
> Error: Missing Dependency: libFLAC.so.7 is needed by package libsndfile

You are on your own.

	[root at el5i /]# rpm -qf /usr/lib/libFLAC.so.7
	flac-1.1.2-28.el5_0.1

	[root at el5i /]# rpm -qf /usr/lib/libsndfile.so.1
	libsndfile-1.0.17-1.el5.rf

Kind regards,
-- 
--   dag wieers,  dag at wieers.com,  http://dag.wieers.com/   --
[Any errors in spelling, tact or fact are transmission errors]



More information about the users mailing list