[users] perl-MIME-Base64 upgrade problem

Dag Wieers dag at wieers.com
Thu Oct 11 10:49:32 CEST 2007


On Thu, 11 Oct 2007, Tomáš Lašťovička wrote:

> Oops, I've sent this reply by mistake only to Dag, so once again...
>
> Dne st 10. října 2007 Dag Wieers napsal(a):
> > Yes, perl-MIME-Base64 is part of the base perl package and as such there
> > is no point in installing it. So for now I would say, do not do that :)
>
> Many thanks... I have discovered what caused the problem...
>
> The machine is a server which was configured by three people and one of them
> compiled perl rpms by hand to satisfy mailscanner... Indeed he didn't know
> anything about yum configuration on that particular machine and his linux
> skills are focused towards Debian anyway...
>
> Later investigation took me to evil install.sh script in Mailscanner, which
> attempts to install some rpm packages with --force parameter. Is there some
> chance to add Mailscanner to rpmforge as someone suggested last week?
>
> Thanks for your help.

In a Unix sysadmin departement you have to set some rules, and one of the
important rules should be:

	Use packages for everything

Even for Debian this should be a rule :)

(Of course for practical reasons sometimes you have to make exceptions,
especially with proprietary software it can be hard or even impossible to
package something)

-- 
--   dag wieers,  dag at wieers.com,  http://dag.wieers.com/   --
[Any errors in spelling, tact or fact are transmission errors]


More information about the users mailing list