[users] Graphviz plugin config

Dave Miller justdave at mozilla.com
Thu Apr 17 00:53:03 CEST 2008


Dave Miller wrote on 4/12/08 2:35 AM:
> Dries Verachtert wrote on 9/3/07 5:12 PM:
>> On Thursday August 30 2007, Stefan Radman wrote:
>>> Package graphviz 2.8 is missing the plugin configuration file
>>>     %{_libdir}/graphviz/config
>>>
>>> Without this file dot reports
>>>     Error: Layout was not done.  Missing layout plugins?
>>>
>>> Adding
>>>
>>>   %post
>>>   %{_bindir}/dot -c
>>>
>>> Will fix this problem
>>>
>>> Reference: http://www.graphviz.org/bugs/b855.html
>>
>> Hello Stefan,
>>
>> Thanks for the information! I've added such a post script and i've 
>> also updated the spec file to 2.14.1 (so possibly i introduced new 
>> bugs :-)  There doesn't seem to be an easy way to generate the config 
>> file without using a %post script.
> 
> This seems to be missing in el5 for some reason?  I just ran into this 
> bug on our servers (the lack of the "dot -c" being run after install) 
> and according to the above message this is supposed to be fixed already. 
>    I only seem to be picking up graphviz 2.8 still, not 2.14.1, also.

Just a bump to make sure this didn't get lost in a spamfilter or 
something, since it's been a few days since I asked, it hasn't been 
fixed yet, and I've seen the people who would likely be able to answer 
replying to more-recent posts.

-- 
Dave Miller                                   http://www.justdave.net/
System Administrator, Mozilla Corporation      http://www.mozilla.com/
Project Leader, Bugzilla Bug Tracking System  http://www.bugzilla.org/



More information about the users mailing list