[users] Graphviz plugin config

Stefan Radman Stefan.Radman at CTBTO.ORG
Thu Apr 17 09:34:00 CEST 2008


Hello Dries,

> Dave Miller wrote on 4/12/08 2:35 AM:
> I only seem to be picking up graphviz 2.8 still, not 2.14.1, also.

>> Dries Verachtert wrote on 9/3/07 5:12 PM:
>> also updated the spec file to 2.14.1 (so possibly i introduced new
bugs :-)  

Graphviz 2.14.1 isn't being built on any platform.
http://dag.wieers.com/rpm/packages/graphviz/_buildlogs/
The buildlog shows unpackaged files (see below).

Cheers
Stefan

RPM build errors:
    Installed (but unpackaged) file(s) found:
   /usr/lib64/graphviz/java/SWIGTYPE_p_Agedge_t.java
   /usr/lib64/graphviz/java/SWIGTYPE_p_Agnode_t.java
   /usr/lib64/graphviz/java/SWIGTYPE_p_Agraph_t.java
   /usr/lib64/graphviz/java/SWIGTYPE_p_Agsym_t.java
   /usr/lib64/graphviz/java/SWIGTYPE_p_FILE.java
   /usr/lib64/graphviz/java/SWIGTYPE_p_p_void.java
   /usr/lib64/graphviz/java/gv.java
   /usr/lib64/graphviz/java/gvJNI.java
   /usr/lib64/graphviz/java/libgv_java.la
   /usr/lib64/graphviz/java/libgv_java.so
   /usr/lib64/graphviz/java/libgv_java.so.0
   /usr/lib64/graphviz/java/libgv_java.so.0.0.0 

> -----Original Message-----
> From: users-bounces at lists.rpmforge.net 
> [mailto:users-bounces at lists.rpmforge.net] On Behalf Of Dave Miller
> Sent: Thursday, 17 April, 2008 00:53
> To: users at lists.rpmforge.net
> Subject: Re: [users] Graphviz plugin config
> 
> Dave Miller wrote on 4/12/08 2:35 AM:
> > Dries Verachtert wrote on 9/3/07 5:12 PM:
> >> On Thursday August 30 2007, Stefan Radman wrote:
> >>> Package graphviz 2.8 is missing the plugin configuration file
> >>>     %{_libdir}/graphviz/config
> >>>
> >>> Without this file dot reports
> >>>     Error: Layout was not done.  Missing layout plugins?
> >>>
> >>> Adding
> >>>
> >>>   %post
> >>>   %{_bindir}/dot -c
> >>>
> >>> Will fix this problem
> >>>
> >>> Reference: http://www.graphviz.org/bugs/b855.html
> >>
> >> Hello Stefan,
> >>
> >> Thanks for the information! I've added such a post script and i've 
> >> also updated the spec file to 2.14.1 (so possibly i introduced new 
> >> bugs :-)  There doesn't seem to be an easy way to generate 
> the config 
> >> file without using a %post script.
> > 
> > This seems to be missing in el5 for some reason?  I just 
> ran into this 
> > bug on our servers (the lack of the "dot -c" being run 
> after install) 
> > and according to the above message this is supposed to be 
> fixed already. 
> >    I only seem to be picking up graphviz 2.8 still, not 
> 2.14.1, also.
> 
> Just a bump to make sure this didn't get lost in a spamfilter or 
> something, since it's been a few days since I asked, it hasn't been 
> fixed yet, and I've seen the people who would likely be able 
> to answer 
> replying to more-recent posts.
> 
> -- 
> Dave Miller                                   http://www.justdave.net/
> System Administrator, Mozilla Corporation      http://www.mozilla.com/
> Project Leader, Bugzilla Bug Tracking System  http://www.bugzilla.org/
> _______________________________________________
> users mailing list
> users at lists.rpmforge.net
> http://lists.rpmforge.net/mailman/listinfo/users
> 



More information about the users mailing list