[users] Re: perl-Proc-Daemon-0.03-1.2.el4.rf

Dag Wieers dag at wieers.com
Thu Apr 17 19:23:05 CEST 2008


On Thu, 17 Apr 2008, Bob Kinney wrote:

>>> [me at server production]# zgrep -c perl-Proc-Daemon 
>>> redhat/el4/en/i386/rpmforge/repodata/*.gz
>>> redhat/el4/en/i386/rpmforge/repodata/filelists.xml.gz:1
>>> redhat/el4/en/i386/rpmforge/repodata/other.xml.gz:1
>>> redhat/el4/en/i386/rpmforge/repodata/primary.xml.gz:2
>>> 
>>> It is there.
>>> 
>> 
>> This is a AMD 64-bit system.  Sorry for not including that in my initial 
>> report:
>> 
>> [root at mail-2 ~]# wget 
>> http://rpmforge.sw.be/redhat/el4/en/x86_64/rpmforge/repodata/filelists.xml.gz 
>> 
>> [root at mail-2 ~]# zgrep -c perl-Proc-Daemon filelists.xml.gz
>> 0
>
> Just wondering if this is something that can be fixed or if I should go a 
> different route and keep a copy in my local repository.

Well, I have no clue why it is missing from the repomd metadata, and not 
from the yum metadata, nor from the apt metadata.

I also fail to see why it would go missing for x86_64 and not for i386 and 
ppc, in all three cases it obviously is there and it is the same package.

What is even more strange, the same routing is handling it for each of 
the architectures, so it cannot be a bug in the repomd logic or the 
createrepo execution.

And since it happens every time the repomd metadata is generated, it was 
not a one time failure. It is actually reproducable.

-- 
--   dag wieers,  dag at wieers.com,  http://dag.wieers.com/   --
[Any errors in spelling, tact or fact are transmission errors]



More information about the users mailing list