[users] Re: missing rpms in el4/x86_64 (was: Re: perl-Proc-Daemon-0.03-1.2.el4.rf)

Dag Wieers dag at wieers.com
Thu Apr 17 19:35:50 CEST 2008


On Thu, 17 Apr 2008, Bob Kinney wrote:

> Bob Kinney wrote:
>>>> [me at server production]# zgrep -c perl-Proc-Daemon 
>>>> redhat/el4/en/i386/rpmforge/repodata/*.gz
>>>> redhat/el4/en/i386/rpmforge/repodata/filelists.xml.gz:1
>>>> redhat/el4/en/i386/rpmforge/repodata/other.xml.gz:1
>>>> redhat/el4/en/i386/rpmforge/repodata/primary.xml.gz:2
>>>> 
>>>> It is there.
>>> 
>>> This is a AMD 64-bit system.  Sorry for not including that in my initial 
>>> report:
>>> 
>>> [root at mail-2 ~]# wget 
>>> http://rpmforge.sw.be/redhat/el4/en/x86_64/rpmforge/repodata/filelists.xml.gz 
>>> 
>>> [root at mail-2 ~]# zgrep -c perl-Proc-Daemon filelists.xml.gz
>>> 0
>> 
>> Just wondering if this is something that can be fixed or if I should go a 
>> different route and keep a copy in my local repository.
>
> I've discovered another package that does not seem to be available for RHEL4 
> 64-bit systems: python-elementree.  This package (along with 
> perl-Proc-Daemon) are available for 32-bit RHEL4 systems, but not 64-bit.
>
> Any insight you can provide regarding these issues would be most appreciated.

I discovered that the version of createrepo on my old infrastructure was 
0.4.6 and on the new infrastructure is 0.4.10. I am now recreating 
metadata to see if that makes a difference and hopefully that fixes this 
problem.

But that means that there is a severe bug in createrepo 0.4.10 :-/

-- 
--   dag wieers,  dag at wieers.com,  http://dag.wieers.com/   --
[Any errors in spelling, tact or fact are transmission errors]



More information about the users mailing list