[users] php-rrdtool and rrdtool

Flaherty, Patrick pflaherty at wsi.com
Wed Apr 23 17:07:06 CEST 2008


I think php-rrdtool needs to be updated. 

rrdtool is on version 1.2.23
php-rrdtool is on version 1.0.50

rrdtool 1.0.50 is as a dependency of php-rrdtool. After installation yum
update it complains about broken dependecies for php-rrdtool because it
wants to upgrade rrdtool to 1.2.23. Can a new version of php-rrdtool be
made? 

Patrick

# yum install rrdtool
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package rrdtool.i386 0:1.2.23-1.el5.rf set to be updated
--> Running transaction check
--> Processing Dependency: perl(RRDp) for package: rrdtool
--> Processing Dependency: rrdtool = 1.0.50 for package: php-rrdtool
--> Processing Dependency: librrd.so.0 for package: php-rrdtool
--> Processing Dependency: perl(RRDs) for package: rrdtool
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package perl-rrdtool.i386 0:1.2.23-1.el5.rf set to be updated
--> Running transaction check
--> Processing Dependency: rrdtool = 1.0.50 for package: php-rrdtool
--> Processing Dependency: librrd.so.0 for package: php-rrdtool
--> Finished Dependency Resolution
Error: Missing Dependency: rrdtool = 1.0.50 is needed by package
php-rrdtool
Error: Missing Dependency: librrd.so.0 is needed by package php-rrdtool



More information about the users mailing list