[users] Repository rpmforge is listed more than once in the configuration

Frank Bures lisfrank at chem.toronto.edu
Thu Jul 31 17:26:31 CEST 2008

Nils Breunese (Lemonbit) wrote:
> Frank Bures wrote:
>> After installation of package rpmforge-release-0.3.6-1.el5.rf.i386.rpm
>> command
>> yum clean all
>> returns:
>> "Repository rpmforge is listed more than once in the configuration"
>> Removing file
>> /etc/yum.repos.d/rpmforge.repo
>> solves the problem, but of course disables the rpmforge repo.
>> Installation is RHEL5.2, no additional repos are involved.
>> Is this a known problem?
>> If yes, are there any solutions?
> Did you inspect /etc/yum.repos.d/rpmforge.repo to see if it was listed 
> more than once?

This file is installed by the rpmforge-release-0.3.6-1.el5.rf.i386.rpm 
package, so it should be correct.  And yes, I inspected it and it was 
listed only once.

>  Are you sure you don't have any rpmforge entries in 
> /etc/yum.conf or other *.repo files in /etc/yum.repos.d?

I checked manually.
When I remove the file /etc/yum.repos.d/rpmforge.repo and run
yum repolist
I do not see the rpmforge repo any more.

The same effect can be achieved by unistalling 
rpmforge-release-0.3.6-1.el5.rf.i386.rpm package by doing
rpm -e

In other words, once the package is installed, I get the error.



Frank Bures, Dept. of Chemistry, University of Toronto, M5S 3H6
fbures at chem.toronto.edu
PGP Public Key: 

Please, reply to the above address only.  <lisfrank> does not accept replies.

More information about the users mailing list