[users] rar.i386 missing deps

Nils Breunese (Lemonbit) nils at lemonbit.nl
Wed Jul 9 17:22:02 CEST 2008


Nicolas Thierry-Mieg wrote:

> on an x86_64 system, installing rar-3.7.0-0.1.beta1.el5.rf.i386 does  
> not pull in i386 versions of required libs.
> Then rar is installed but does not function.
>
> $ rar
> rar: error while loading shared libraries: libstdc++.so.6: cannot  
> open shared object file: No such file or directory
>
> $ which rar
> /usr/bin/rar
>
> $ rpm -qf /usr/bin/rar
> rar-3.7.0-0.1.beta1.el5.rf.i386
>
> $ ldd /usr/bin/rar
>        linux-gate.so.1 =>  (0xffffe000)
>        libstdc++.so.6 => not found
>        libm.so.6 => /lib/libm.so.6 (0x0054b000)
>        libgcc_s.so.1 => not found
>        libc.so.6 => /lib/libc.so.6 (0x003ac000)
>        /lib/ld-linux.so.2 (0x0038e000)
>
> $ rpm -qf /lib/libm.so.6 /lib/libc.so.6 /lib/ld-linux.so.2
> glibc-2.5-24.i686
> glibc-2.5-24.i686
> glibc-2.5-24.i686
>
>
> The rar.i386 package should depend on i386 versions of glibc (which  
> I have), but also of libstdc++ and libgcc (which I don't).
>
> After installing i386 versions of libstdc++ and libgcc, rar works as  
> expected.

Looking at http://dag.wieers.com/rpm/packages/rar/ I see there were  
x86_64 versions of older releases of rar, but it seems they weren't  
created for the 3.6 and 3.7 beta versions.

Nils Breunese.



More information about the users mailing list