[suggest] perl modules with conflicting man pages

Dag Wieers dag at wieers.com
Mon Jun 30 18:25:54 CEST 2008


On Mon, 30 Jun 2008, Peter Willis wrote:

> Hi, there are a couple perl modules in rpmforge which upgrade older versions 
> in perl core, but the perl modules have man pages which exist in perl core 
> and prevent them from being installed. These seem to be requirements for 
> other perl modules so it is preventing yum from installing other modules. 
> Here are some example errors from yum:
>
>  file /usr/share/man/man3/IO::Socket::UNIX.3pm.gz from install of 
> perl-IO-1.2301-1.el5.rf conflicts with file from package 
> perl-5.8.8-10.el5_0.2
>
>  file /usr/bin/enc2xs from install of perl-Encode-2.25-1.el5.rf conflicts 
> with file from package perl-5.8.8-10.el5_0.2
>  file /usr/share/man/man3/Encode.3pm.gz from install of 
> perl-Encode-2.25-1.el5.rf conflicts with file from package 
> perl-5.8.8-10.el5_0.2
>
>  file /usr/share/man/man3/Getopt::Long.3pm.gz from install of 
> perl-Getopt-Long-2.37-1.el5.rf conflicts with file from package 
> perl-5.8.8-10.el5_0.2
>
>  file /usr/share/man/man3/Test::Harness.3pm.gz from install of 
> perl-Test-Harness-3.11-1.el5.rf conflicts with file from package 
> perl-5.8.8-10.el5_0.2

The solution is to disable building those packages on RHEL5, rather then 
to remove the manpage.

-- 
--   dag wieers,  dag at wieers.com,  http://dag.wieers.com/   --
[Any errors in spelling, tact or fact are transmission errors]



More information about the users mailing list