[users] Strange dependency for audacious-libs

Dries Verachtert dries at ulyssis.org
Fri Jun 13 16:30:58 CEST 2008


On Monday 09 June 2008 08:54:23 pm Heiko Adams wrote:
> Hi,
>
> this is the output when trying to install audacious-libs:
> > [root at Ostfriesland ~]# yum erase audacious-libs
> > Loading "merge-conf" plugin
> > Loading "refresh-updatesd" plugin
> > Loading "fastestmirror" plugin
> > Loading "kernel-module" plugin
> > Loading "fedorakmod" plugin
> > Loading "repolist" plugin
> > Loading "priorities" plugin
> > Loading "installonlyn" plugin
> > Loading "skip-broken" plugin
> > Setting up Remove Process
> > No Match for argument: audacious-libs
> > No Packages marked for removal
> > [root at Ostfriesland ~]# yum install audacious-libs
> > Loading "merge-conf" plugin
> > Loading "refresh-updatesd" plugin
> > Loading "fastestmirror" plugin
> > Loading "kernel-module" plugin
> > Loading "fedorakmod" plugin
> > Loading "repolist" plugin
> > Loading "priorities" plugin
> > Loading "installonlyn" plugin
> > Loading "skip-broken" plugin
> > Setting up Install Process
> > Setting up repositories
> > Loading mirror speeds from cached hostfile
> > Reading repository metadata in from local files
> > Excluding Packages from Extra Packages for Enterprise Linux 5 - i386
> > Finished
> > Excluding Packages from Red Hat Enterprise 5 - RPMforge.net - dag
> > Finished
> > 1204 packages excluded due to repository priority protections
> > Parsing package install arguments
> > Resolving Dependencies
> > --> Populating transaction set with selected packages. Please wait.
> > ---> Package audacious-libs.i386 0:1.3.2-5.el5.rf set to be updated
> > --> Running transaction check
> > --> Processing Dependency: libmcs.so.1.0.0 for package: audacious-libs
> > --> Finished Dependency Resolution
> > Error: Missing Dependency: libmcs.so.1.0.0 is needed by package
> > audacious-libs
>
> But doing a yum list *mcs* results the following output:
> > libxfce4mcs.i386                         4.4.2-1.el5.centos     installed
> > mcs.i386                                 0.4.1-3.el5.centos     installed
> > mcs-devel.i386                           0.4.1-3.el5.centos     installed
> > mcs-libs.i386                            0.4.1-3.el5.centos     installed
> > mcstrans.i386                            0.2.7-1.el5            installed
> > xfce-mcs-manager.i386                    4.4.2-1.el5.centos     installed
> > xfce-mcs-plugins.i386                    4.4.2-1.el5.centos     installed
> > Available Packages
> > libxfce4mcs-devel.i386                   4.4.2-1.el5.centos     extras
> > xfce-mcs-manager-devel.i386              4.4.2-1.el5.centos     extras
>
> So what's going wrong here??

libmcs.so.1.0.0 can be found in libmcs-0.6.0-1.el5.rf.i386.rpm which can be 
found for example at http://dag.wieers.com/rpm/packages/libmcs/  .. no idea 
why it's not found by yum.

Dries




More information about the users mailing list