[users] Transaction Check Error

Brandon Amaro omega13a at sbcglobal.net
Sat Jun 28 07:19:17 CEST 2008


I'm not sure if I'm the only one getting this error. I've been getting 
it for the past two days when my server does its nightly update 
check/install. If anyone out there knows how to fix it, please let me know.

Loading "priorities" plugin
Loading "fastestmirror" plugin
Determining fastest mirrors
 * kbs-CentOS-Extras: centos.karan.org
 * kbs-CentOS-Misc: centos.karan.org
 * rpmforge: apt.sw.be
 * base: sunsite.utk.edu
 * updates: mirror.trouble-free.net
 * addons: mirror.raystedman.net
 * extras: styx.biochem.wfubmc.edu
142 packages excluded due to repository priority protections
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package perl-Compress-Raw-Zlib.i386 0:2.011-1.el5.rf set to be updated
---> Package samba.i386 0:3.0.28-1.el5_2.1 set to be updated
---> Package perl-DBI.i386 0:1.605-1.el5.rf set to be updated
---> Package perl-Apache-ASP.noarch 0:2.61-1.el5.rf set to be updated
---> Package kernel-headers.i386 0:2.6.18-92.1.6.el5 set to be updated
---> Package samba-client.i386 0:3.0.28-1.el5_2.1 set to be updated
---> Package perl-IO-Compress-Zlib.noarch 0:2.011-1.el5.rf set to be updated
---> Package samba-common.i386 0:3.0.28-1.el5_2.1 set to be updated
---> Package samba-swat.i386 0:3.0.28-1.el5_2.1 set to be updated
---> Package perl.i386 4:5.8.8-10.el5_2.3 set to be updated
---> Package perl-Compress-Zlib.noarch 0:2.011-1.el5.rf set to be updated
---> Package perl-IO-Compress-Base.noarch 0:2.011-1.el5.rf set to be updated
---> Package cairo.i386 0:1.2.4-5.el5 set to be updated
---> Package perl-Font-AFM.noarch 0:1.20-1.el5.rf set to be updated
---> Package pm-utils.i386 0:0.99.3-6.el5.centos.19 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 cairo                   i386       1.2.4-5.el5      base              394 k
 kernel-headers          i386       2.6.18-92.1.6.el5  updates           846 k
 perl                    i386       4:5.8.8-10.el5_2.3  updates            12 M
 perl-Apache-ASP         noarch     2.61-1.el5.rf    rpmforge          357 k
 perl-Compress-Raw-Zlib  i386       2.011-1.el5.rf   rpmforge          163 k
 perl-Compress-Zlib      noarch     2.011-1.el5.rf   rpmforge           34 k
 perl-DBI                i386       1.605-1.el5.rf   rpmforge          864 k
 perl-Font-AFM           noarch     1.20-1.el5.rf    rpmforge           19 k
 perl-IO-Compress-Base   noarch     2.011-1.el5.rf   rpmforge           56 k
 perl-IO-Compress-Zlib   noarch     2.011-1.el5.rf   rpmforge          142 k
 pm-utils                i386       0.99.3-6.el5.centos.19  base               66 k
 samba                   i386       3.0.28-1.el5_2.1  updates            16 M
 samba-client            i386       3.0.28-1.el5_2.1  updates           4.9 M
 samba-common            i386       3.0.28-1.el5_2.1  updates           8.7 M
 samba-swat              i386       3.0.28-1.el5_2.1  updates           7.4 M

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update      15 Package(s)         
Remove       0 Package(s)         

Total download size: 52 M
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  file /usr/share/man/man3/IO.3pm.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-IO-1.2301-1.el5.rf
  file /usr/share/man/man3/IO::Dir.3pm.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-IO-1.2301-1.el5.rf
  file /usr/share/man/man3/IO::File.3pm.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-IO-1.2301-1.el5.rf
  file /usr/share/man/man3/IO::Handle.3pm.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-IO-1.2301-1.el5.rf
  file /usr/share/man/man3/IO::Pipe.3pm.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-IO-1.2301-1.el5.rf
  file /usr/share/man/man3/IO::Poll.3pm.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-IO-1.2301-1.el5.rf
  file /usr/share/man/man3/IO::Seekable.3pm.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-IO-1.2301-1.el5.rf
  file /usr/share/man/man3/IO::Select.3pm.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-IO-1.2301-1.el5.rf
  file /usr/share/man/man3/IO::Socket.3pm.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-IO-1.2301-1.el5.rf
  file /usr/share/man/man3/IO::Socket::INET.3pm.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-IO-1.2301-1.el5.rf
  file /usr/share/man/man3/IO::Socket::UNIX.3pm.gz from install of perl-5.8.8-10.el5_2.3 conflicts with file from package perl-IO-1.2301-1.el5.rf

Error Summary
-------------


omega13a



More information about the users mailing list