[users] perl-Net-Packet package broken?

Henning Markussen hm at mib.dk
Sat Mar 8 16:43:19 CET 2008


Hi

In a process to install http://dns.measurement-factory.com/tools/dnsdump/

There is a req. for
     * Net::Pcap
     * Net::Packet
     * Net::DNS


So I tried to install them via yum, but it breaks

With yum I just get this output

[root at mail tmp]# yum install perl-Net-Packet
Loading "protectbase" plugin
Loading "fastestmirror" plugin
Setting up Install Process
Setting up repositories
Loading mirror speeds from cached hostfile
Reading repository metadata in from local files
194 packages excluded due to repository protections
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package perl-Net-Packet.noarch 0:3.25-1.el4.rf set to be updated
--> Running transaction check
--> Processing Dependency: perl(Net::Libdnet) for package: perl-Net-Packet
--> Processing Dependency: perl(v5.6.1) for package: perl-Net-Packet
--> Processing Dependency: perl(Net::Write::Layer2) for package: 
perl-Net-Packet
--> Processing Dependency: perl(Class::Gomor::Array) for package: 
perl-Net-Packet
--> Processing Dependency: perl(Net::IPv6Addr) for package: perl-Net-Packet
--> Processing Dependency: perl(Bit::Vector) for package: perl-Net-Packet
--> Processing Dependency: perl(Net::Write::Layer4) for package: 
perl-Net-Packet
--> Processing Dependency: perl(Socket6) for package: perl-Net-Packet
--> Processing Dependency: perl(Net::IPv4Addr) for package: perl-Net-Packet
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package perl-Bit-Vector.i386 0:6.3-3 set to be updated
---> Package perl-Net-Libdnet.i386 0:0.01-1.el4.rf set to be updated
---> Package perl-Net-IPv4Addr.noarch 0:0.10-1.2.el4.rf set to be updated
---> Package perl-Class-Gomor.noarch 0:1.01-1.el4.rf set to be updated
---> Package perl-Socket6.i386 0:0.20-1.el4.rf set to be updated
--> Running transaction check
--> Processing Dependency: perl(v5.6.1) for package: perl-Net-Packet
--> Processing Dependency: perl(Net::Write::Layer2) for package: 
perl-Net-Packet
--> Processing Dependency: perl(Net::IPv6Addr) for package: perl-Net-Packet
--> Processing Dependency: libdnet.1 for package: perl-Net-Libdnet
--> Processing Dependency: perl(Net::Write::Layer4) for package: 
perl-Net-Packet
--> Processing Dependency: perl(Carp::Clan) for package: perl-Bit-Vector
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package libdnet.i386 0:1.11-1.2.el4.rf set to be updated
---> Package perl-Date-Calc.i386 0:5.3-9 set to be updated
--> Running transaction check
--> Processing Dependency: perl(v5.6.1) for package: perl-Net-Packet
--> Processing Dependency: perl(Net::Write::Layer2) for package: 
perl-Net-Packet
--> Processing Dependency: perl(Net::Write::Layer4) for package: 
perl-Net-Packet
--> Processing Dependency: perl(Net::IPv6Addr) for package: perl-Net-Packet
--> Finished Dependency Resolution
Error: Missing Dependency: perl(v5.6.1) is needed by package perl-Net-Packet
Error: Missing Dependency: perl(Net::Write::Layer2) is needed by package 
perl-Net-Packet
Error: Missing Dependency: perl(Net::IPv6Addr) is needed by package 
perl-Net-Packet
Error: Missing Dependency: perl(Net::Write::Layer4) is needed by package 
perl-Net-Packet


I know that apt can be better in resolving dependency's so I also that, 
but I also get a error with apt:

[root at mail tmp]# apt-get install perl-Net-Packet
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
   perl-Net-Packet: Depends: perl(v5.6.1) but it is not installable
                    Depends: perl(Net::Write::Layer2) but it is not 
installable
                    Depends: perl(Net::Write::Layer4) but it is not 
installable
                    Depends: perl(Net::IPv6Addr) but it is not installable
E: Broken packages


Any ideas to if the error is in the package or on my system?

- Henning



More information about the users mailing list