[users] ImapSync Dependency MisMatch

John Thomas gmane-2006-04-16 at jt-socal.com
Sat Mar 15 23:46:18 CET 2008


FYI, I removed  perl-Mail-IMAPClient.noarch 3.05-1.el4.rf
and installed
http://dag.wieers.com/rpm/packages/perl-Mail-IMAPClient/perl-Mail-IMAPClient-2.2.9-1.2.el4.rf.noarch.rpm
then imapsync worked fine.

It seems IMAPSYNC should have a dependency on perl-Mail-IMAPClient 2.2.9 
despite the 3.05 in the repository.

John Thomas wrote:
> Based on the following, and my scant knowledge, I have concluded the 
> imapsync spec should have a dependency for perl-mail-imapclient that is 
> 2.2.9.  However, rpmforge has 3.05.
> 
> First, a Freshmeat link in case that is of interest:
> http://freshmeat.net/projects/imapsync/
> 
> [root at mail-backup bin]# imapsync
> Subroutine Authuser redefined at /usr/bin/imapsync line 1870.
> imapsync needs perl lib Mail::IMAPClient release 2.2.9 exactly, future 
> imapsync release may suppoort 3.0.x, but sorry not now
> # Looks like your test died before it could output anything.
> [root at mail-home bin]# yum list 'perl-mail-imap*'
> Setting up repositories
> Reading repository metadata in from local files
> Reducing CentOS.Karan.Org-EL4 - Stable to included packages only
> Finished
> Excluding Packages from CentOS-4 - Base
> Finished
> Installed Packages
> perl-Mail-IMAPClient.noarch              3.05-1.el4.rf          installed
> 


-- 
Sincerely,
John Thomas



More information about the users mailing list