[users] Nagios upgrade

Grant McChesney grantmc at gmail.com
Tue Nov 4 16:42:36 CET 2008


On Sun, Nov 2, 2008 at 2:57 AM, Christoph Maser <cmr at financial.com> wrote:

> Am Sonntag, den 02.11.2008, 03:55 +0100 schrieb Grant McChesney:
> > Christoph:
> >
> > Thanks for providing Nagios 3.  I just finished upgrading from version
> > 2.  The upgrade went as expected;  I updated the .cfgs and moved them
> > to /etc/nagios/objects/ and ran nagios -v nagios.cfg until all the
> > errors disappeared.
> >
> > Grant
>
> Grant
>
> why did you move your config files? There should be no need to do that.
> Concerning the mentioned errors, either you did not post them or maybe
> your mail had an attachment wich was removed.
>
> Chris
>
>
Sorry, I didn't include the errors in my previous email.  I'll address them
here.

Nagios wouldn't initially start because time_change_threshold was null.  I
set it to 900 after reading http://markmail.org/message/eu5v6kcljg3oahyp

Another issue I ran into was a change in the commands.cfg.  It looks like
some of the command names have changed.  See following:

Nagios 2 commands.cfg:
notify-by-email
host-notify-by-email

Nagios 3 commands.cfg:
notify-service-by-email
notify-host-by-email


I decided to move my hosts and services cfgs to the objects directory after
reading through the nagios.cfg.  It looked it was best place for them.

Let me reemphasize these were all minor issues, and I was up and running
with Nagios in under an hour.


Grant
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.repoforge.org/pipermail/users/attachments/20081104/50f1121d/attachment-0004.html>


More information about the users mailing list