[users] request: smplayer

Yury V. Zaytsev yury at shurup.com
Fri Nov 28 10:07:44 CET 2008


Hi,

On Thu, 2008-11-27 at 18:10 -0800, MargoAndTodd wrote:

> uic: File generated with too recent version of Qt Designer (4.0 vs.
> 3.3.6)

I think you really need to learn how to interpret error messages: this
one clearly says you are trying to build a program written with Qt4
against your older Qt3 distribution. Try

yum install qt4 qt4-devel

and make it default for your user e.g. adding it to your PATH

PATH=/usr/lib/qt4/bin:$PATH

> Dag, would you build this rpm for us?

Well, I tried to compile it against Qt4, but first off, I had to resave
the UI-files with Qt Designer 4.2, since topMargin and friends are only
supported on Qt4.3+ and also disable subtitle download functionality
from HTTPS hosts, since QHttp only supports it starting from Qt4.3.

So you can download my precompiled RPM and modified tbz here:

http://rpm.zaytsev.net/smplayer/

and the patch for the developer if they want to stay compatible with the
CentOS 5.x line here (I don't have enough time to bear with them):

http://rpm.zaytsev.net/smplayer/smplayer-0.6.5.1-centos5-zyv.patch

If anyone wants to use it for packaging, no problem here. By the way, it
says that the mplayer version from rpmforge is outdated so it can't
reliable control it. Any chance for us to get an update?
 
-- 
Sincerely yours,
Yury V. Zaytsev




More information about the users mailing list