[users] Missing dependency on perl-DBD-mysql

Hugo van der Kooij hvdkooij at vanderkooij.org
Sat Oct 18 18:32:06 CEST 2008


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Christoph Maser wrote:
> This is a conflict between perl-DBD-mysql from rpmforge and
> perl-DBD-MySQL from CentOS/RHEL
> 
> You should use protectbase or priorities plugin as described here:
> http://wiki.centos.org/PackageManagement/Yum/Priorities
> http://wiki.centos.org/PackageManagement/Yum/ProtectBase
> 
> CentOS/RHEL depends on perl-DBD-MySQL (note the capital letters) wich is
> not provided by the rpmforge package. You can see the difference if you
> try yum provides perl-DBD-mysql vs yum provides perl-DBD-MySQL

Just a simple thought:

If the spec file of perl-DBD-mysql would add a line like:

Provides: perl-DBD-MySQL

Wouldn't that solve a number of conflicts?

Hugo.


- --
hvdkooij at vanderkooij.org               http://hugo.vanderkooij.org/
PGP/GPG? Use: http://hugo.vanderkooij.org/0x58F19981.asc

	A: Yes.
	>Q: Are you sure?
	>>A: Because it reverses the logical flow of conversation.
	>>>Q: Why is top posting frowned upon?

Bored? Click on http://spamornot.org/ and rate those images.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org

iD8DBQFI+g+FBvzDRVjxmYERAp8TAJ9UJ16wxfLATnHRSdD703mCs82dygCfcsHZ
UAnlg31xgD/tK/ZBmVvtJe4=
=whO0
-----END PGP SIGNATURE-----



More information about the users mailing list